Skip to content

Commit

Permalink
media-fonts/cantarell: 0.0.25 → 0.101, complete redesign
Browse files Browse the repository at this point in the history
Redesigned from scratch to interpolate cleanly from thin to extra bold.

Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
EvaSDK committed May 27, 2018
1 parent d3285a0 commit 78cabde
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-fonts/cantarell/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cantarell-fonts-0.0.25.tar.xz 351768 BLAKE2B cfdd7570c99db9e75658369df9eb243ddb6290dfe8017bcff12edf876134ba185083e70676369962a2a9f35365e92268625b47da286aca640927fb7a47073295 SHA512 c09c3ecb3d4c50f613234398fabd327ca92b8abbc27082e8e98f2944f3dd9f0c2ff4c022ff5e5503a86e724bb8e2fbf6cd081f8a29e91b4209f5bf0e32168c3e
DIST cantarell-fonts-0.101.tar.xz 263480 BLAKE2B 79652cf87088a8fe505895cad1f2474e0cb52e4be8a977ae06442a0e8ca6ba6a7f93c811b14e56fd5e61a17c97175b2374d180e435cbac00af8c10b272461802 SHA512 52dbd8358de7e20146e627ab0b1298efb97ee335e45d8e63bab7c3a7d05314d0bb94ac448e34af4c6f7212623185a9e03a30eb24acee4915142e40af0086bbfb
50 changes: 50 additions & 0 deletions media-fonts/cantarell/cantarell-0.101.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME_ORG_MODULE="${PN}-fonts"

inherit font gnome.org meson

DESCRIPTION="Default fontset for GNOME Shell"
HOMEPAGE="https://wiki.gnome.org/Projects/CantarellFonts"

LICENSE="OFL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""

RDEPEND="media-libs/fontconfig"
DEPEND="
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"

# This ebuild does not install any binaries
RESTRICT="binchecks strip"

# Font eclass settings
FONT_CONF=("${S}/fontconfig/31-cantarell.conf")
FONT_S="${S}/prebuilt"
FONT_SUFFIX="otf"

src_prepare() {
# Leave prebuilt font installation to font.eclass
sed -e "/subdir('prebuilt')/d" -i meson.build || die

default
}

src_configure() {
local emesonargs=(
-Dfontsdir=${FONTDIR}
-Duseprebuilt=true
)
meson_src_configure
}

src_install() {
local DOCS=( NEWS README.md )
meson_src_install
font_src_install
}

0 comments on commit 78cabde

Please sign in to comment.