Skip to content

Commit

Permalink
app-cdr/cdemu: Bump to 3.2.5
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 19, 2021
1 parent decae6d commit 78fb318
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-cdr/cdemu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cdemu-client-3.2.4.tar.bz2 44284 BLAKE2B c57fe09bef7112933a93fac9944eaff957e01692ec1ddec7fd443aa780f8b3d85d0bd640611337d896843de3ab00d09e093c293776a52afa85f781bdde7f4250 SHA512 2e10cb345e261ddaa6da68ee626770ed65749b1ea64c2bbbf0f3a2e96184c2906834886754e87e3161c3056473e5ee0dc20672ce7cb48232e6bef1c93cb80550
DIST cdemu-client-3.2.5.tar.xz 41596 BLAKE2B 5b3e5a16f9daa0ab2c670a8cba54af380894e668c87a64a5e2126777d6725420d9bb7f41290ca69eba12e20db97b00cc74aea3df9694ef331e7a571b913820b1 SHA512 d143705607507503cd7828f02e7a0fbe5d33f15e28ce61f453567d8635ed863c5b508ed2b1964f034d846ecdea752bd3dfb565350174db3e06cf7d29c2f828bf
61 changes: 61 additions & 0 deletions app-cdr/cdemu/cdemu-3.2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )

inherit bash-completion-r1 cmake python-single-r1 xdg-utils

MY_P=cdemu-client-${PV}
DESCRIPTION="Command-line tool for controlling cdemu-daemon"
HOMEPAGE="https://cdemu.sourceforge.io"
SRC_URI="https://download.sourceforge.net/cdemu/cdemu-client/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+cdemu-daemon"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
')
cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
BDEPEND="${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
>=sys-devel/gettext-0.18
virtual/pkgconfig"

DOCS=( AUTHORS README )

src_prepare() {
cmake_src_prepare

python_fix_shebang src/cdemu
}

src_configure() {
local mycmakeargs=(
-DPOST_INSTALL_HOOKS=OFF
# requires bash-completion as BDEPEND, better install it manually
-DENABLE_BASH_COMPLETION=OFF
)
cmake_src_configure
}

src_install() {
cmake_src_install
newbashcomp data/cdemu-bash-completion.sh cdemu
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit 78fb318

Please sign in to comment.