forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Volkmar W. Pogatzki <[email protected]> Closes: gentoo#25617 Signed-off-by: Florian Schmaus <[email protected]>
- Loading branch information
Showing
2 changed files
with
60 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST commons-daemon-1.2.4-src.tar.gz 281929 BLAKE2B 877f1c31024a2f3e4796abdd11059bd636444f5c856b998a39761fb0b221467e986586fef43463a4d01b4d4f7a562f9f8c658b94a124cd356b0a70cc185c0030 SHA512 36e9cb3153ca763bfaaa71575a1584610254f1ce4c0f666ff7bbc628311405430536413525c9c777e4364eea62a247fb084750d837e84a62d9fce92a61909d56 | ||
DIST commons-daemon-1.3.1-src.tar.gz 287642 BLAKE2B 02e85a5534af7f804a0374789506ee25ee8313987c68153974aa938b983745ae44d579f17deb362764d1a03b04bc552115bd69ef28b4f7d3bbb06f3bb4199814 SHA512 b810ac152f8296d980a4fb3786eff9d147b234dc2377df5fe1bded0824c694c9e82a7ef50b0a63c3e6432dfc4684a3aa2ce8d583aacb740bd4664c3dfb8b8f16 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,59 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
# Skeleton command: | ||
# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/daemon/source/commons-daemon-1.2.4-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-daemon-1.2.4.ebuild | ||
|
||
EAPI=8 | ||
|
||
JAVA_PKG_IUSE="doc source" | ||
MAVEN_ID="commons-daemon:commons-daemon:1.3.1" | ||
# JAVA_TESTING_FRAMEWORKS="junit-4" | ||
|
||
inherit java-pkg-2 java-pkg-simple toolchain-funcs | ||
|
||
DESCRIPTION="Tools to allow Java programs to run as UNIX daemons" | ||
HOMEPAGE="https://commons.apache.org/proper/commons-daemon/" | ||
SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc64 ~x86" | ||
|
||
DEPEND=" | ||
>=virtual/jdk-1.8:* | ||
" | ||
|
||
RDEPEND=" | ||
>=virtual/jre-1.8:* | ||
" | ||
|
||
DOCS=( {CONTRIBUTING,README}.md {HOWTO-RELEASE,NOTICE,RELEASE-NOTES}.txt ) | ||
HTML_DOCS=( PROPOSAL.html ) | ||
|
||
S="${WORKDIR}/${P}-src" | ||
|
||
JAVA_ENCODING="iso-8859-1" | ||
|
||
JAVA_SRC_DIR="src/main/java" | ||
|
||
# There is only org/apache/commons/daemon/SimpleDaemon.java | ||
# which is not even run upstream ( mvn test ). | ||
# JAVA_TEST_GENTOO_CLASSPATH="junit-4" | ||
# JAVA_TEST_SRC_DIR="src/test/java" | ||
|
||
src_compile() { | ||
java-pkg-simple_src_compile | ||
|
||
pushd src/native/unix || die | ||
./configure | ||
emake AR="$(tc-getAR)" | ||
popd | ||
} | ||
|
||
src_install() { | ||
default # https://bugs.gentoo.org/789582 | ||
java-pkg-simple_src_install | ||
|
||
dobin src/native/unix/jsvc | ||
} |