Skip to content

Commit

Permalink
net-fs/autofs: version bump 5.1.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
dlan17 committed Jun 15, 2016
1 parent 13e565e commit 79280cb
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-fs/autofs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST autofs-5.0.7.tar.bz2 319117 SHA256 08c4304d8076dc80c14df559bc5fd821b67ef345
DIST autofs-5.1.0.tar.xz 288288 SHA256 f4b343797e6df03627a9fd41bda6fd85acb84aa3fdd15694eec03ec90a52bc27 SHA512 a455df8d93bc29aa87c3f928edea5bb3f91ab9c7bd7bbca8eb1370fdcc4c32b3a30d7f2c0d79800f65ac08716634f118c81ede7e816ef567048e4361aafac476 WHIRLPOOL ed265b1a9e697c08e802f0a17c0de482e5f1f292aecf8ab42cd7cf7177a605b0337ff6ab81b72950fc38687d31c47f9c01ff68cd0a8f10952a59b69a590e19ca
DIST autofs-5.1.1-patches-0.tar.lzma 41178 SHA256 ef9f94aacff845d29d3118c73ca7d08199d40a7de5edae1025d341530e7dc2b4 SHA512 5c3ba26711401b3f9dc8cd36d3a85b1a8efce409621efedfc4f1caf2a15536646f6f89a79b8e12c703d3b3a4627ecda8c800386ebff34e20fdfad39041d91aa4 WHIRLPOOL d3d91c432e643911a4d8b5463e056aa50c717c08287e6ccf75bf1d6ca071460cc709aa32387f53cbe763de27b86eef1e26ab75a2fd334c783fd024b9f1d47ba3
DIST autofs-5.1.1.tar.xz 290300 SHA256 e08ff0ef9ff365d87b6c33dca136d20e4e07675197a324f2816894cb437021c3 SHA512 37c0f10ee06bbfc76059ff9ae54d9b462f1c2bc39e8779e96dd5bfc2b07055606c0710f1c3de95e6f099edd2c5bb5a6f8a341be989d7554bf80011bfbe90c905 WHIRLPOOL 063e7bcabb3e93a17e8e7da75e6b42af59769e794e3b31240762a4617cc2ac626b4b4985a38455bdca56753fb897fed1a3173c633f1f9a594e79f891dc41f523
DIST autofs-5.1.2.tar.xz 294792 SHA256 88b7de39088aead983e02072a7b753d5ee52ce419c8913f7a3d4ff5521313f0c SHA512 435bcb41c9d467947c194d879e46692b5976131b8e923793bdeac34f70420ede740c4d70ec393413fff0b1010495ac7fe5fa8b45a59d15a2430ecae9ec3fe7e1 WHIRLPOOL d0e53d1d41bf31c8bf6358053b1a0668dcc0a84ee92ff69ade86a6731bfb0945f41cab5b2dd62d7c086219095c20db43c91a074ce321fd5db870a5f16af7bce0
115 changes: 115 additions & 0 deletions net-fs/autofs/autofs-5.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

AUTOTOOLS_AUTORECONF=true
AUTOTOOLS_IN_SOURCE_BUILD=true

inherit autotools-utils linux-info multilib systemd toolchain-funcs

PATCH_VER=
[[ -n ${PATCH_VER} ]] && \
PATCHSET_URI="https://dev.gentoo.org/~jlec/distfiles/${P}-patches-${PATCH_VER}.tar.lzma"

DESCRIPTION="Kernel based automounter"
HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
SRC_URI="
mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.xz
${PATCHSET_URI}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="-dmalloc hesiod ldap libtirpc mount-locking sasl"

# USE="sasl" adds SASL support to the LDAP module which will not be build. If
# SASL support should be available, please add "ldap" to the USE flags.
REQUIRED_USE="sasl? ( ldap )"

# currently, sasl code assumes the presence of kerberosV
RDEPEND=">=sys-apps/util-linux-2.20
dmalloc? ( dev-libs/dmalloc[threads] )
hesiod? ( net-dns/hesiod )
ldap? ( >=net-nds/openldap-2.0
sasl? (
dev-libs/cyrus-sasl
dev-libs/libxml2
virtual/krb5
)
)
libtirpc? ( net-libs/libtirpc )"

DEPEND="${RDEPEND}
sys-devel/flex
virtual/yacc"

CONFIG_CHECK="~AUTOFS4_FS"

src_prepare() {
# Upstream's patchset
if [[ -n ${PATCH_VER} ]]; then
EPATCH_SUFFIX="patch" \
epatch "${WORKDIR}"/patches
fi

sed -i -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die #bug #479492
autotools-utils_src_prepare
}

src_configure() {
# bug #483716
tc-export AR
# --with-confdir is for bug #361481
# --with-mapdir is for bug #385113
local myeconfargs=(
--with-confdir=/etc/conf.d
--with-mapdir=/etc/autofs
$(use_with dmalloc)
$(use_with ldap openldap)
$(use_with libtirpc)
$(use_with sasl)
$(use_with hesiod)
$(use_enable mount-locking)
--disable-ext-env
--enable-sloppy-mount # bug #453778
--enable-force-shutdown
--enable-ignore-busy
--with-systemd="$(systemd_get_unitdir)" #bug #479492
RANLIB="$(type -P $(tc-getRANLIB))" # bug #483716
)
autotools-utils_src_configure
}

src_compile() {
autotools-utils_src_compile DONTSTRIP=1
}

src_install() {
autotools-utils_src_install

if kernel_is -lt 2 6 30; then
# kernel patches
docinto patches
dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
fi
newinitd "${FILESDIR}"/autofs5.initd autofs
insinto etc/autofs
newins "${FILESDIR}"/autofs5-auto.master auto.master
}

pkg_postinst() {
if kernel_is -lt 2 6 30; then
elog "This version of ${PN} requires a kernel with autofs4 supporting"
elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
elog "been installed into"
elog "${EROOT}usr/share/doc/${P}/patches."
elog "For further instructions how to patch the kernel, please refer to"
elog "${EROOT}usr/share/doc/${P}/INSTALL."
elog
fi
elog "If you plan on using autofs for automounting remote NFS mounts,"
elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
elog "are running."
}

0 comments on commit 79280cb

Please sign in to comment.