forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
91 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST aws-cli-1.34.10.gh.tar.gz 2788517 BLAKE2B 8b110119087836435f3e0ef29a6cfe35dd3a387bff4051cc94b9beb4e8a2d929460ac14c659ef0c3a37cb6378e7910eca7c92975f04ac2d1b2140e2aedd0eb60 SHA512 46844c919a3998040897ccdf48cf4ed616a9debc125d03386f53bce66597a8cc077f9be7735b133085c3225c9402acd94da85fffbd1205e732ad5cd5b56bf9a2 | ||
DIST aws-cli-1.34.14.gh.tar.gz 2790437 BLAKE2B df3355ac11561ac7f6e2a7c707d08de0b3335b4321ef3f5730a9abd6a23dfa909e0ba27367e705c56ce7223bbb7d1d436759457f0f92a0d7b4da21e6392a0c6b SHA512 be707816a1f6a53ab32870eaed498bfd47782b07c146af79d6f5cc1153e0b180788be1cc48cbf21f8850d04a79b3255bcfa2456079c57585e4779083bc5353e1 | ||
DIST aws-cli-1.34.15.gh.tar.gz 2790865 BLAKE2B e9c89028942df21d880997c61ee261110271402223869b740bbb51bd8b787c26b2b7aa4b335968665260549bde8571c97350ccaf0c32df1c28267ae454b99001 SHA512 f7628e664b515f46b85978d5662165a889db5db004aa6d32be9fa0ee6b9b9a4fd46281df5c8f3e6218a9adc81d365e4251d0e5ce3601c2b6da9dd4ac567c24d9 | ||
DIST aws-cli-1.34.5.gh.tar.gz 2774000 BLAKE2B 34368cc257a99a9c7212972bcff91c46352db8659c5fe98101c9192cb674663b9090b3608d88875875d24488869fcb571e8602532219cf0a25bc3159f3bf285c SHA512 4dc305e4e659fbbd17a265b6c9589e20c63eec671114a67687c225081f8095a8627499441f78d76e6fa0da59b03ae078833227db0434c97572a7f5f7c4a43e5a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,90 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{10..13} ) | ||
|
||
inherit bash-completion-r1 distutils-r1 | ||
|
||
MY_P=aws-cli-${PV} | ||
DESCRIPTION="Universal Command Line Environment for AWS" | ||
HOMEPAGE=" | ||
https://github.com/aws/aws-cli/ | ||
https://pypi.org/project/awscli/ | ||
" | ||
SRC_URI=" | ||
https://github.com/aws/aws-cli/archive/${PV}.tar.gz | ||
-> ${MY_P}.gh.tar.gz | ||
" | ||
S=${WORKDIR}/${MY_P} | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86" | ||
|
||
# botocore is x.(y+1).z | ||
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)" | ||
RDEPEND=" | ||
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}] | ||
dev-python/colorama[${PYTHON_USEDEP}] | ||
dev-python/docutils[${PYTHON_USEDEP}] | ||
dev-python/rsa[${PYTHON_USEDEP}] | ||
>=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
!app-admin/awscli-bin | ||
" | ||
BDEPEND=" | ||
test? ( | ||
dev-python/packaging[${PYTHON_USEDEP}] | ||
dev-python/pytest-forked[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
EPYTEST_XDIST=1 | ||
distutils_enable_tests pytest | ||
|
||
src_prepare() { | ||
# do not rely on bundled deps in botocore (sic!) | ||
find -name '*.py' -exec sed -i \ | ||
-e 's:from botocore[.]vendored import:import:' \ | ||
-e 's:from botocore[.]vendored[.]:from :' \ | ||
{} + || die | ||
# strip overzealous upper bounds on requirements | ||
sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die | ||
distutils-r1_src_prepare | ||
} | ||
|
||
python_test() { | ||
local serial_tests=( | ||
tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success | ||
tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success} | ||
tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success | ||
tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking | ||
tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows | ||
tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking | ||
tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success | ||
tests/unit/customizations/test_sessionmanager.py | ||
tests/unit/test_compat.py::TestIgnoreUserSignals | ||
tests/unit/test_help.py | ||
tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored | ||
) | ||
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 | ||
EPYTEST_XDIST= epytest "${serial_tests[@]}" | ||
|
||
local EPYTEST_DESELECT=( "${serial_tests[@]}" ) | ||
# integration tests require AWS credentials and Internet access | ||
epytest tests/{functional,unit} | ||
} | ||
|
||
python_install_all() { | ||
newbashcomp bin/aws_bash_completer aws | ||
|
||
insinto /usr/share/zsh/site-functions | ||
newins bin/aws_zsh_completer.sh _aws | ||
|
||
distutils-r1_python_install_all | ||
|
||
rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die | ||
} |