forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
2 changed files
with
254 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST curl-7.42.1.tar.bz2 3327304 SHA256 e2905973391ec2dfd7743a8034ad10eeb58dab8b3a297e7892a41a7999cac887 SHA512 846c2d2bc73d39240686bf54e4c02553a1ca1640123fef30538cfc8a6317650f4cb9f1cc882016b7826ef9c84cb92adbfa24e55d59d2e7203bdcb12835fb474f WHIRLPOOL ff826e11812334ebca650c54788bf1b81b2927f7b9607b10e79cc70f6d1f9b893aebc816914158243510ffaead3b15a21ce10e7180eeb175b0b503e9ac8b0c6e | ||
DIST curl-7.43.0.tar.bz2 3363770 SHA256 baa654a1122530483ccc1c58cc112fec3724a82c11c6a389f1e6a37dc8858df9 SHA512 0b06ec078680619f56a458ac115142546134917331b71b73ed2c0371c480034dac7ed848814be0dd1e752154c53e48b9e0276b83f75a690df6cfb480ab331272 WHIRLPOOL e5c97b3cbf0f9915f62a100ce2972e6cffcabae753770c2f0a1fc3bcef3a66c0a2d4d7e361b00f442d62eca3b0d9526eb34f6b043fb655648180e81ef630a527 | ||
DIST curl-7.44.0.tar.bz2 3398814 SHA256 1e2541bae6582bb697c0fbae49e1d3e6fad5d05d5aa80dbd6f072e0a44341814 SHA512 250a0aa6ba9917cd7666ff180efb02d994d1040759b94370b8c3bb215467d632b867f111b555228ab7f9a7ecd1e5d205204b29cbc003797dd315f628376a376d WHIRLPOOL 6725c44667016365f6c83a75cae1fc1f4d310256194a7f6b2738f642250b5229a565047c9f4882f07dd2daf0a4b5149e22ce91d62c26a52d73c087e50c64f6cd | ||
DIST curl-7.45.0.tar.bz2 3473632 SHA256 65154e66b9f8a442b57c436904639507b4ac37ec13d6f8a48248f1b4012b98ea SHA512 71c557c69eb8d160f74a9b76ef83a46ce33ef4e8a66a261699329583dadf10205b4ba4783f92d4e6c8724f6610ffade5b0a9f189b0a7b9169ff839dfc8980481 WHIRLPOOL afc1627cebb64c9111f943fe63d95c8a998934fd02e3b8d12f061d23b174b7475c48451ecc1713ce54771455a6465238aa3b818b0eb9ba5c86ffd06eb1f2bc76 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,253 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
inherit autotools eutils prefix multilib-minimal | ||
|
||
DESCRIPTION="A Client that groks URLs" | ||
HOMEPAGE="http://curl.haxx.se/" | ||
SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
IUSE="adns http2 idn ipv6 kerberos ldap metalink rtmp samba ssh ssl static-libs test threads" | ||
IUSE+=" curl_ssl_axtls curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl curl_ssl_polarssl curl_ssl_winssl" | ||
IUSE+=" elibc_Winnt" | ||
|
||
#lead to lots of false negatives, bug #285669 | ||
RESTRICT="test" | ||
|
||
RDEPEND="ldap? ( >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}] ) | ||
ssl? ( | ||
curl_ssl_axtls? ( | ||
>=net-libs/axtls-1.4.9-r1[${MULTILIB_USEDEP}] | ||
app-misc/ca-certificates | ||
) | ||
curl_ssl_gnutls? ( | ||
|| ( | ||
( | ||
>=net-libs/gnutls-3.2.15[static-libs?,${MULTILIB_USEDEP}] | ||
>=dev-libs/nettle-2.6[${MULTILIB_USEDEP}] | ||
) | ||
( | ||
=net-libs/gnutls-2.12*[nettle,static-libs?,${MULTILIB_USEDEP}] | ||
>=dev-libs/nettle-2.6[${MULTILIB_USEDEP}] | ||
) | ||
( | ||
=net-libs/gnutls-2.12*[-nettle,static-libs?,${MULTILIB_USEDEP}] | ||
>=dev-libs/libgcrypt-1.5.3[static-libs?,${MULTILIB_USEDEP}] | ||
) | ||
) | ||
app-misc/ca-certificates | ||
) | ||
curl_ssl_libressl? ( | ||
dev-libs/libressl[static-libs?,${MULTILIB_USEDEP}] | ||
) | ||
curl_ssl_openssl? ( | ||
>=dev-libs/openssl-1.0.1h-r2[static-libs?,${MULTILIB_USEDEP}] | ||
) | ||
curl_ssl_nss? ( | ||
>=dev-libs/nss-3.15.4[${MULTILIB_USEDEP}] | ||
app-misc/ca-certificates | ||
) | ||
curl_ssl_polarssl? ( | ||
>=net-libs/polarssl-1.3.4:=[${MULTILIB_USEDEP}] | ||
app-misc/ca-certificates | ||
) | ||
) | ||
http2? ( net-libs/nghttp2[${MULTILIB_USEDEP}] ) | ||
idn? ( >=net-dns/libidn-1.28[static-libs?,${MULTILIB_USEDEP}] ) | ||
adns? ( >=net-dns/c-ares-1.10.0-r1[${MULTILIB_USEDEP}] ) | ||
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] ) | ||
metalink? ( >=media-libs/libmetalink-0.1.1[${MULTILIB_USEDEP}] ) | ||
rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] ) | ||
ssh? ( >=net-libs/libssh2-1.4.3[static-libs?,${MULTILIB_USEDEP}] ) | ||
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] | ||
abi_x86_32? ( | ||
!<=app-emulation/emul-linux-x86-baselibs-20140508-r13 | ||
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] | ||
)" | ||
|
||
# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303 | ||
# rtmp? ( | ||
# media-video/rtmpdump | ||
# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] ) | ||
# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] ) | ||
# ) | ||
|
||
# ssl providers to be added: | ||
# fbopenssl $(use_with spnego) | ||
|
||
# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html | ||
|
||
DEPEND="${RDEPEND} | ||
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] | ||
test? ( | ||
sys-apps/diffutils | ||
dev-lang/perl | ||
)" | ||
|
||
# c-ares must be disabled for threads | ||
# only one ssl provider can be enabled | ||
REQUIRED_USE=" | ||
curl_ssl_winssl? ( elibc_Winnt ) | ||
threads? ( !adns ) | ||
ssl? ( | ||
^^ ( | ||
curl_ssl_axtls | ||
curl_ssl_gnutls | ||
curl_ssl_libressl | ||
curl_ssl_openssl | ||
curl_ssl_nss | ||
curl_ssl_polarssl | ||
curl_ssl_winssl | ||
) | ||
)" | ||
|
||
DOCS=( CHANGES README docs/FEATURES docs/INTERNALS \ | ||
docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE) | ||
|
||
MULTILIB_WRAPPED_HEADERS=( | ||
/usr/include/curl/curlbuild.h | ||
) | ||
|
||
MULTILIB_CHOST_TOOLS=( | ||
/usr/bin/curl-config | ||
) | ||
|
||
src_prepare() { | ||
epatch \ | ||
"${FILESDIR}"/${PN}-7.30.0-prefix.patch \ | ||
"${FILESDIR}"/${PN}-respect-cflags-3.patch \ | ||
"${FILESDIR}"/${PN}-fix-gnutls-nettle.patch | ||
|
||
sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241 | ||
|
||
epatch_user | ||
eprefixify curl-config.in | ||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
einfo "\033[1;32m**************************************************\033[00m" | ||
|
||
# We make use of the fact that later flags override earlier ones | ||
# So start with all ssl providers off until proven otherwise | ||
local myconf=() | ||
myconf+=( --without-axtls --without-gnutls --without-nss --without-polarssl --without-ssl --without-winssl ) | ||
myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt ) | ||
if use ssl ; then | ||
if use curl_ssl_axtls; then | ||
einfo "SSL provided by axtls" | ||
einfo "NOTE: axtls is meant for embedded systems and" | ||
einfo "may not be the best choice as an ssl provider" | ||
myconf+=( --with-axtls ) | ||
fi | ||
if use curl_ssl_gnutls; then | ||
einfo "SSL provided by gnutls" | ||
if has_version ">=net-libs/gnutls-3.2.15[${MULTILIB_USEDEP}]" || has_version "=net-libs/gnutls-2.12*[nettle,${MULTILIB_USEDEP}]"; then | ||
einfo "gnutls compiled with dev-libs/nettle" | ||
myconf+=( --with-gnutls --with-nettle ) | ||
else | ||
einfo "gnutls compiled with dev-libs/libgcrypt" | ||
myconf+=( --with-gnutls --without-nettle ) | ||
fi | ||
fi | ||
if use curl_ssl_nss; then | ||
einfo "SSL provided by nss" | ||
myconf+=( --with-nss ) | ||
fi | ||
if use curl_ssl_polarssl; then | ||
einfo "SSL provided by polarssl" | ||
einfo "NOTE: polarssl is meant for embedded systems and" | ||
einfo "may not be the best choice as an ssl provider" | ||
myconf+=( --with-polarssl ) | ||
fi | ||
if use curl_ssl_libressl; then | ||
einfo "SSL provided by LibreSSL" | ||
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs ) | ||
fi | ||
if use curl_ssl_openssl; then | ||
einfo "SSL provided by openssl" | ||
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs ) | ||
fi | ||
if use curl_ssl_winssl; then | ||
einfo "SSL provided by Windows" | ||
myconf+=( --with-winssl ) | ||
fi | ||
else | ||
einfo "SSL disabled" | ||
fi | ||
einfo "\033[1;32m**************************************************\033[00m" | ||
|
||
# These configuration options are organized alphabetically | ||
# within each category. This should make it easier if we | ||
# ever decide to make any of them contingent on USE flags: | ||
# 1) protocols first. To see them all do | ||
# 'grep SUPPORT_PROTOCOLS configure.ac' | ||
# 2) --enable/disable options second. | ||
# 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort | ||
# 3) --with/without options third. | ||
# grep -- --with configure | grep Check | awk '{ print $4 }' | sort | ||
ECONF_SOURCE="${S}" \ | ||
econf \ | ||
--enable-dict \ | ||
--enable-file \ | ||
--enable-ftp \ | ||
--enable-gopher \ | ||
--enable-http \ | ||
--enable-imap \ | ||
$(use_enable ldap) \ | ||
$(use_enable ldap ldaps) \ | ||
--enable-pop3 \ | ||
--enable-rt \ | ||
--enable-rtsp \ | ||
$(use_enable samba smb) \ | ||
$(use_with ssh libssh2) \ | ||
--enable-smtp \ | ||
--enable-telnet \ | ||
--enable-tftp \ | ||
$(use_enable adns ares) \ | ||
--enable-cookies \ | ||
--enable-hidden-symbols \ | ||
$(use_enable ipv6) \ | ||
--enable-largefile \ | ||
--enable-manual \ | ||
--enable-proxy \ | ||
--disable-soname-bump \ | ||
--disable-sspi \ | ||
$(use_enable static-libs static) \ | ||
$(use_enable threads threaded-resolver) \ | ||
--disable-versioned-symbols \ | ||
--without-cyassl \ | ||
--without-darwinssl \ | ||
$(use_with idn libidn) \ | ||
$(use_with kerberos gssapi "${EPREFIX}"/usr) \ | ||
--without-krb4 \ | ||
$(use_with metalink libmetalink) \ | ||
$(use_with http2 nghttp2) \ | ||
$(use_with rtmp librtmp) \ | ||
--without-spnego \ | ||
--without-winidn \ | ||
--with-zlib \ | ||
"${myconf[@]}" | ||
|
||
if ! multilib_is_native_abi; then | ||
# avoid building the client | ||
sed -i -e '/SUBDIRS/s:src::' Makefile || die | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
prune_libtool_files --all | ||
|
||
rm -rf "${ED}"/etc/ | ||
|
||
# https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976 | ||
insinto /usr/share/aclocal | ||
doins docs/libcurl/libcurl.m4 | ||
} |