Skip to content

Commit

Permalink
dev-php/composer: bump to v2.0.13
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Apr 27, 2021
1 parent db4a6ab commit 79e844a
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/composer/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST composer-1.10.22.tar.gz 429521 BLAKE2B da7a340b63fd2540886e0fe9252a115bffdfdddfb9cc5063b296fa4026275390641a761260597f9f4421bfcde62c5f8c9fd4757e41a8278ff0063f905d3a5b50 SHA512 e1a9e22d3e0673a0bbdbc4a97a330e15ce2b6b9e81a6bfc97a6d5918713d02fc414a36393e8760830418d9bde0664cbbcd8e454d6c6be14db585565a3eeb452b
DIST composer-2.0.11.tar.gz 494980 BLAKE2B 7095b27ff770c890261a622d2b96febeca226fa307fe14d74df0e723fdf2ade8b04ceb85a25317f4f6b2f5cfc9dce27223738e61a734d6b4c3b4069c03ad551a SHA512 7f2429b4cf0dd237b17d393837e18e12886a9b0641130c8d6e490b37f85b8beee54a2b58003e63b7b157104edf70dff211ca44255ee60bf904b3fb7d57f186d2
DIST composer-2.0.12.tar.gz 497394 BLAKE2B 6d9fe821466714a6b96faef66b8e934b6e9a680734d7a010727a8e6921ba4e8058fcc01d824b6ccd87ad38dbe6dbfbe8b646d4fc40634721992e58ddf729fe9d SHA512 cede1331eef88ad202b6aac4b9a394bf45358ef069880e33fee13f12fb6039888ba75a6bf2a17c1cc7e514a2e909be2c99cedee4e98a8b76d8f67b3039cacfff
DIST composer-2.0.13.tar.gz 497819 BLAKE2B ab51556ff65b0c2822d5419bb6dde2c775c91ed210af6ab84f272db0ea823866d75090173663d517cd36163bbe04ce06f597c670fce45b595716baaf05253d8e SHA512 b16425e0553f69c23e636cc51711e2e433125ac55a29d21c66eead4b40080379449868810e9b443996e3959feae2be6ed9c9a100bc5e3f84d210654dd160887f
78 changes: 78 additions & 0 deletions dev-php/composer/composer-2.0.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

DESCRIPTION="Dependency Manager for PHP"
HOMEPAGE="https://github.com/composer/composer"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="dev-lang/php:*[curl]
>=dev-php/ca-bundle-1.0
dev-php/fedora-autoloader
>=dev-php/jsonlint-1.4
>=dev-php/json-schema-5.2.10
>=dev-php/metadata-minifier-1.0
>=dev-php/phar-utils-1.0
>=dev-php/psr-log-1.0
>=dev-php/reactphp-promise-2.7
>=dev-php/semver-3.0
>=dev-php/spdx-licenses-1.2
>=dev-php/symfony-console-2.8.52
>=dev-php/symfony-filesystem-2.8.52
>=dev-php/symfony-finder-2.8.52
>=dev-php/symfony-process-2.8.52
>=dev-php/xdebug-handler-1.1"

src_prepare() {
default

mkdir vendor || die

phpab \
--output vendor/autoload.php \
--template "${FILESDIR}"/autoload.php.tpl \
--basedir src \
src \
|| die

cat >> vendor/autoload.php <<EOF || die "failed to extend autoload.php"
// Dependencies
\Fedora\Autoloader\Dependencies::required([
'/usr/share/php/Composer/CaBundle/autoload.php',
'/usr/share/php/Composer/MetadataMinifier/autoload.php',
'/usr/share/php/Composer/Semver/autoload.php',
'/usr/share/php/Composer/Spdx/autoload.php',
'/usr/share/php/Composer/XdebugHandler/autoload.php',
'/usr/share/php/JsonSchema/autoload.php',
'/usr/share/php/Psr/Log/autoload.php',
'/usr/share/php/Seld/JsonLint/autoload.php',
'/usr/share/php/Seld/PharUtils/autoload.php',
'/usr/share/php/Symfony/Component/Console/autoload.php',
'/usr/share/php/Symfony/Component/Filesystem/autoload.php',
'/usr/share/php/Symfony/Component/Finder/autoload.php',
'/usr/share/php/Symfony/Component/Process/autoload.php',
'/usr/share/php/React/Promise/autoload.php'
]);
EOF
}

src_install() {
insinto "/usr/share/${PN}"

# Composer expects the LICENSE file to be there, and the
# easiest thing to do is to give it what it wants.
doins -r LICENSE res src vendor

exeinto "/usr/share/${PN}/bin"
doexe "bin/${PN}"
dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"

dodoc CHANGELOG.md README.md doc/*.md
dodoc -r doc/articles doc/faqs
}

0 comments on commit 79e844a

Please sign in to comment.