Skip to content

Commit

Permalink
dev-python/python-xmp-toolkit: EAPI 8, PEP517
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 26, 2022
1 parent fd17249 commit 7a2e07f
Showing 1 changed file with 46 additions and 0 deletions.
46 changes: 46 additions & 0 deletions dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )

inherit distutils-r1

if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/python-xmp-toolkit/${PN}.git"
else
SRC_URI="https://github.com/python-xmp-toolkit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Library for working with XMP metadata"
HOMEPAGE="https://github.com/python-xmp-toolkit/python-xmp-toolkit/ https://pypi.org/project/python-xmp-toolkit/"

LICENSE="BSD"
SLOT="0"
IUSE="doc test"
RESTRICT="!test? ( test )"

DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( media-libs/exempi )
"
RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
"

PATCHES=( "${FILESDIR}"/${P}-test.patch )

distutils_enable_tests unittest

python_compile_all() {
use doc && emake -C docs html
}

python_install_all() {
use doc && local HTML_DOCS=( docs/.build/html/. )
distutils-r1_python_install_all
}

0 comments on commit 7a2e07f

Please sign in to comment.