Skip to content

Commit

Permalink
gui-apps/foot: add 1.15.2
Browse files Browse the repository at this point in the history
Signed-off-by: Arsen Arsenović <[email protected]>
  • Loading branch information
ArsenArsen committed Jul 30, 2023
1 parent 77aa847 commit 7a4bc3c
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-apps/foot/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST foot-1.13.1.tar.gz 496955 BLAKE2B 48155439cd11123320908e67a968304903f96a550
DIST foot-1.14.0.tar.gz 509863 BLAKE2B fe7e26c3c70e99c00a121e1214f0003dbc8fc986a020e135e18feba515d9e194ba92a494bb33c22e20b96957e87ac5ed721511a9a104481bc24f40ceb9e0e8bd SHA512 379f1acafa8b3fd600c57974d79eef1a7e8a4630015aaeb8a0c491c0903ba1cd24b4fa578880f6cf6c9a09a8566c0609f4cccff9b5f65ade409684ec704c8ce4
DIST foot-1.15.0.tar.gz 520829 BLAKE2B e86dba4c000ae3b290d207a2edef5e3b4240d27dd00c7e174312c3921ce670950c3396bd0d557733c87bcbeacc28fc9768916dc12fc703e5ebfd175afa818f01 SHA512 b0d4ad025010e2dbe30e1cfbc5d41c7dabc2d2d99872193134ddbca043d0d63daf85f2e81bcfa4aabcf7335c38e952bb1e46a9d28a1cd8ac62fc14c6bf87cb20
DIST foot-1.15.1.tar.gz 523399 BLAKE2B 6e9296dcb8fd16fb77ec1e7a7668b46da31f83343f6b5fcafdb2514570ec7a356e1ba6308024331b66fdaca34eb86fd69dea6d5ab71a576ae13740a03d4245b7 SHA512 14605ba6e18b7ffc0961a3f00d275af2d885ec3d194123406d4fef21c6ec193c37ddee0a58f3a70853a72aabdbfc768bfc5fa1c516ad6cb669056c1c6dea990f
DIST foot-1.15.2.tar.gz 524743 BLAKE2B 7c6f573e733210f532238eb0d2385d49f61fcb531265ff1474b93cd092c8d860f27b11e6b36c506379d7874b9cc285825f56518817a2623fdde93b7c3d0e4fc6 SHA512 931231e0518950d3ac42625befab63ecc9a253bb870ea4c439d1110c40b31c15d049b9fc1e2a6282927737a9f6d7cd3278d42dffa6a57c3c1366e342e1e79622
74 changes: 74 additions & 0 deletions gui-apps/foot/foot-1.15.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson xdg systemd

DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
HOMEPAGE="https://codeberg.org/dnkl/foot"
SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="+grapheme-clustering test"
RESTRICT="!test? ( test )"

COMMON_DEPEND="
dev-libs/wayland
media-libs/fcft
media-libs/fontconfig
x11-libs/libxkbcommon
x11-libs/pixman
grapheme-clustering? (
dev-libs/libutf8proc:=
media-libs/fcft[harfbuzz]
)
"
DEPEND="
${COMMON_DEPEND}
>=dev-libs/tllist-1.1.0
dev-libs/wayland-protocols
"
RDEPEND="
${COMMON_DEPEND}
|| (
>=sys-libs/ncurses-6.3[-minimal]
~gui-apps/foot-terminfo-${PV}
)
"
BDEPEND="
app-text/scdoc
dev-util/wayland-scanner
"

src_prepare() {
default
# disable the systemd dep, we install the unit file manually
sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
}

src_configure() {
local emesonargs=(
$(meson_feature grapheme-clustering)
$(meson_use test tests)
-Dthemes=true
-Dime=true
-Dterminfo=disabled
)
meson_src_configure

sed 's|@bindir@|/usr/bin|g' "${S}"/foot-server.service.in > foot-server.service || die
}

src_install() {
local DOCS=( CHANGELOG.md README.md LICENSE )
meson_src_install

# foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
# we handle this via DOCS and dodoc instead.
rm -r "${ED}/usr/share/doc/${PN}" || die
systemd_douserunit foot-server.service "${S}"/foot-server.socket
}

0 comments on commit 7a4bc3c

Please sign in to comment.