forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-benchmarks/contest: add -std=gnu89 to CFLAGS to restore pre-GCC5 …
…semantics Gentoo-Bug: 570250 In addition, modernize to EAPI=6 and amend patches accordingly. Package-Manager: portage-2.2.26
- Loading branch information
1 parent
9ec73cf
commit 7ad37ba
Showing
3 changed files
with
62 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit flag-o-matic toolchain-funcs | ||
|
||
DESCRIPTION="Test system responsiveness to compare different kernels" | ||
HOMEPAGE="http://members.optusnet.com.au/ckolivas/contest/" | ||
SRC_URI="http://members.optusnet.com.au/ckolivas/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
|
||
RDEPEND=">=app-benchmarks/dbench-2.0" | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-fortify_sources.patch" | ||
"${FILESDIR}/${P}-fix-buildsystem.patch" | ||
) | ||
|
||
src_prepare () { | ||
# fix #570250 by restoring pre-GCC5 inline semantics | ||
append-cflags -std=gnu89 | ||
|
||
default | ||
tc-export CC | ||
} | ||
src_compile() { | ||
emake | ||
} | ||
|
||
src_install() { | ||
dobin contest | ||
doman contest.1 | ||
dodoc README | ||
} |
22 changes: 22 additions & 0 deletions
22
app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
--- contest-0.61/Makefile | ||
+++ contest-0.61/Makefile | ||
@@ -1,8 +1,8 @@ | ||
INSTPATH=/usr | ||
BIN=$(INSTPATH)/bin | ||
MAN=$(INSTPATH)/man | ||
-CC=gcc | ||
-CFLAGS= -W -Wall -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations \ | ||
+CC?=gcc | ||
+CFLAGS?= -W -Wall -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations \ | ||
-g -O2 | ||
|
||
ifeq ($(shell uname),FreeBSD) | ||
@@ -14,7 +14,7 @@ | ||
list_load.o | ||
|
||
contest: $(objs) | ||
- $(CC) $(CFLAGS) -o $@ $(objs) $(KVM) | ||
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(objs) $(KVM) | ||
contest.1.gz: contest.1 | ||
gzip -c contest.1 > contest.1.gz | ||
install: contest contest.1.gz |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters