Skip to content

Commit

Permalink
dev-libs/libuv: Version 1.34.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Dec 4, 2019
1 parent af9426a commit 7aeab18
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libuv/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST libuv-1.28.0.tar.gz 1218769 BLAKE2B 444881479688144b36559a258f998e99e663d85
DIST libuv-1.31.0.tar.gz 1238566 BLAKE2B d6a9b92dc8a6f28dd89f65e6d1b7ff4921c7d591c13965e27304d3ca38f25d0436a1ab690a09238c511bb787bcecbaf2cc34a214a388515eef039fc5742ec7ee SHA512 bb27ab86f2f6e9c2b22e768216097db2b69e468967b48bf1a15d17c36b445355ee4bd356f59bbd1bcf7d7c0d3f68b2c6660f999a2cc0660033eb5e3775499409
DIST libuv-1.32.0.tar.gz 1242643 BLAKE2B 39520790200c70a417103416a6c2a389aad7b67878872c3733cf0dbca5ace012e45da088b0695e8dcbf55859635b6d67672581bc13c444d078ffa536bd3d0c39 SHA512 3e043a56fd09fdaf3c89f81b3dff70a385ba8a59ec065447c95199a0e45da323b8545fb13b50139c557541357450103a88297fdc921832de661f3e2700173b96
DIST libuv-1.33.1.tar.gz 1251944 BLAKE2B fc20883dbd96df0d91fbcc75255ae2a371cd2d4e00a747cf23e7b9dbc2e4663ca71be2eef601b18c58e39f64cb3ad348684db4c683bcdd85a3fea4c28a578417 SHA512 0200aae2d38c26f537658955479cbc54fb69d5d8cbbccf3016cea319b2c46b1f311ca7a8fc289f14532acbbf2905cf96b17353b8b92bf09802424c372701d1d5
DIST libuv-1.34.0.tar.gz 1253950 BLAKE2B 3317709603409e009e24b5ff419bbac03927e75f0c0a37f0c6d8f558d027a25e883eec60a46928bb3533308a6f77a9834841e62ad9162df3c8cca1c3ae24a75e SHA512 30811311268179984fdc44209eb0e9ac4c6df08fa30790b75916ae838b23c2578a8a043340fbde86bcd5a373dcc335dec5fe88209560613876ca3272fd99c9e8
47 changes: 47 additions & 0 deletions dev-libs/libuv/libuv-1.34.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit autotools multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
RESTRICT="test"

DEPEND="sys-devel/libtool
virtual/pkgconfig[${MULTILIB_USEDEP}]"

src_prepare() {
default

echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
> m4/libuv-extra-automake-flags.m4 || die

# upstream fails to ship a configure script
eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
cc_cv_cflags__g=no
$(use_enable static-libs static)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_test() {
mkdir "${BUILD_DIR}"/test || die
cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
default
}

multilib_src_install_all() {
einstalldocs
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 7aeab18

Please sign in to comment.