Skip to content

Commit

Permalink
app-emulation/vagrant: bump to 2.0.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/653510
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
hydrapolic authored and Amynka committed Apr 20, 2018
1 parent 123da54 commit 7aec299
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/vagrant/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST vagrant-2.0.0.tar.gz 1142850 BLAKE2B a37baa3166e812635a8ce7e27280108660a347b8cfed396f29cb8f7b7266b5dc47501be6793a95d9bbaf289dd3be3bcef67ff37c35b51987a328194f275ae7f9 SHA512 ee9059dfd205253d6f978fd225d85eef5a281532a1992bc9382eb713c95a0280d4b6518460106227237ae4e93cf5e2eaf670bd378627c3e9696b0fe9a2427ac1
DIST vagrant-2.0.1.tar.gz 1153702 BLAKE2B 66c15ab3bf6fd5904e25d4689b6ce70b5c87c833e1ed943b49f53d6ce63924486d65c2db3990625a1fd971fae5e7961f7b9d0624e71576daa7967cbccf21c202 SHA512 4458fd819cfcbf732dcbb5e334986afc986e3da4f4ea883260ed9b7ff8dd90ef9b0078c067a1bf7fbf51562f235ab447234762a38aa0ac539974f6205f6d9cfd
DIST vagrant-2.0.2.tar.gz 1177773 BLAKE2B 7624ce0bbc5f606bff89a0ef7d9d562f5caeea50b2b13744aef5e037f0b7861ccd2b6450f1686f4285027540b795539ef548ddadaf2f6c1476c87717078ebc7f SHA512 27e8157cf8a8d102a0ca328403410639bd4a9f7cb90d443f5be3ca912aeb6177208b26ba9751b49d98b5ba1e92f8bec74db0baca4cd22051d5ef6d3aca558f3a
DIST vagrant-2.0.3.tar.gz 1181697 BLAKE2B fa33063b52e6b9c9a1212a8833ee70c1d45dc4d09f039882337e2571bac5fcb2c5cf5199c7a39ea539873cc445ec768946a12c0a8bb7b03f51e133d56388bf15 SHA512 c62366c2e2b190a19efeae3379573c9e534b296db68152f284f3d80e9fdff4260e246c40206076e222bda3cf8f4ecbd02656c65aa35c15606b8638d7a8fca200
79 changes: 79 additions & 0 deletions app-emulation/vagrant/vagrant-2.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
USE_RUBY="ruby22 ruby23"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
RUBY_FAKEGEM_TASK_DOC=""

inherit bash-completion-r1 ruby-fakegem

DESCRIPTION="A tool for building and distributing development environments"
HOMEPAGE="http://vagrantup.com/"
SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+virtualbox"
RESTRICT="test"

RDEPEND="${RDEPEND}
app-arch/libarchive
net-misc/curl
virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"

ruby_add_rdepend "
>=dev-ruby/childprocess-0.6.0
>=dev-ruby/erubis-2.7.0
<dev-ruby/i18n-0.8.0:*
>=dev-ruby/listen-3.1.5
>=dev-ruby/hashicorp-checkpoint-0.1.5
>=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
>=dev-ruby/net-ssh-4.2.0:*
>=dev-ruby/net-sftp-2.1
>=dev-ruby/net-scp-1.2.0
|| ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
>=dev-ruby/nokogiri-1.7.1
<dev-ruby/mime-types-3:*
"

ruby_add_bdepend "
>=dev-ruby/rake-12.0.0
"

all_ruby_prepare() {
# remove bundler support
sed -i '/[Bb]undler/d' Rakefile || die
rm Gemfile || die

# loosen dependencies
sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
-e '/ruby_dep/s/<=/>=/' \
-i ${PN}.gemspec || die

# remove windows-specific gems
sed -e '/wdm\|winrm/d' \
-i ${PN}.gemspec || die

# remove bsd-specific gems
sed -e '/rb-kqueue/d' \
-i ${PN}.gemspec || die

sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in-r1" > "${PN}" || die
}

all_ruby_install() {
newbashcomp contrib/bash/completion.sh ${PN}
all_fakegem_install

# provide executable similar to upstream:
# https://github.com/mitchellh/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
dobin "${PN}"

# directory for plugins.json
keepdir /var/lib/vagrant
}

0 comments on commit 7aec299

Please sign in to comment.