forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <[email protected]> Signed-off-by: Mikle Kolyada <[email protected]>
- Loading branch information
1 parent
f4154ed
commit 7b14583
Showing
2 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch" | ||
HOMEPAGE="https://www.elastic.co/products/beats" | ||
SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
RESTRICT="test" | ||
|
||
DEPEND=">=dev-lang/go-1.11.2" | ||
RDEPEND="!app-admin/filebeat-bin" | ||
|
||
# Do not complain about CFLAGS etc since go projects do not use them. | ||
QA_FLAGS_IGNORED='.*' | ||
|
||
S="${WORKDIR}/src/github.com/elastic/beats" | ||
|
||
src_unpack() { | ||
mkdir -p "${S%/*}" || die | ||
default | ||
mv beats-${PV} "${S}" || die | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# avoid Elastic license | ||
rm -r x-pack || die | ||
|
||
# use ${PV} instead of git commit id | ||
sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die | ||
} | ||
|
||
src_compile() { | ||
GOPATH="${WORKDIR}" emake -C "${S}/filebeat" | ||
} | ||
|
||
src_install() { | ||
keepdir /var/{lib,log}/${PN} | ||
|
||
fperms 0750 /var/{lib,log}/${PN} | ||
|
||
newconfd "${FILESDIR}/${PN}.confd" ${PN} | ||
newinitd "${FILESDIR}/${PN}.initd.1" ${PN} | ||
|
||
docinto examples | ||
dodoc ${PN}/{filebeat.yml,filebeat.reference.yml} | ||
|
||
dobin filebeat/filebeat | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ -n "${REPLACING_VERSIONS}" ]]; then | ||
elog "Please read the migration guide at:" | ||
elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html" | ||
elog "" | ||
fi | ||
|
||
elog "Example configurations:" | ||
elog "${EROOT}/usr/share/doc/${PF}/examples" | ||
} |