Skip to content

Commit

Permalink
app-admin/filebeat: bump to 6.5.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <[email protected]>
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
hydrapolic authored and Zlogene committed Dec 22, 2018
1 parent f4154ed commit 7b14583
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/filebeat/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST filebeat-5.6.13.tar.gz 18212575 BLAKE2B a0b8810523cecd1c6c87a69832c92b39fdc
DIST filebeat-6.3.2.tar.gz 20923316 BLAKE2B 70ac7e574f94a6141a7c6a1bd0af45ddbda3d01d6ea006c90ea341d2df03cac320d53496833cace3b394b9433251ea68a248dafdc8e28a85a6014314d5a2f3c4 SHA512 3d6ed03c9286bc7784444ad979b1398fcd70d870be184f912202ee5fab7c0ff23df639f445ec14cfcfd4d41ef648f33e88c2959f3c5f966fd3986884a223623a
DIST filebeat-6.4.3.tar.gz 22085261 BLAKE2B 466580ba371d02bd0b51bd80f0e8d9766f2af1d371f88cd01144a648cd8d5488ca54447e925e9014790a836009d76be9eec9ef9b14a102287d3f4a71b852d20d SHA512 c28d9939c2082b586ddf744b4e18427096290987efd74f7ea03d2632a1cdcbc5dd2b043ee7ceeb0457098faeb52abbac57652077c518112fb65858954ee27f34
DIST filebeat-6.5.2.tar.gz 25277622 BLAKE2B 9a18270e7f147528a324b8ec2c06780ab92bae5a67456d141e66a21cbf8962ef085b7e750476f204e01265cf56cbdec1a3dbe298b037ed59cae8a850205cbd2e SHA512 a4417ecc9ef46ac0b4263434baa4c04058fba82ff312fc8dd9cfd94cbd4c0536ad19a47a18c09707e84360af2eacc64e23715d76359360c38f91e5e7ef8e8d99
DIST filebeat-6.5.4.tar.gz 25286147 BLAKE2B c3eca03c8e8e2b863918f3fe65bdea46b351739569f5570daac3e321963e98190331c5bf99c2451db5faa615620e023d2fd9c73060d4d775392a86a2f5578d80 SHA512 a48b9ae267ec80c1b45e4e07644f8080f8ba280da5c3543022b73472eb70de9d836cfffd387e576298becf9313d2cfa67d835158442f163b1a1bd0e72df31297
66 changes: 66 additions & 0 deletions app-admin/filebeat/filebeat-6.5.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
HOMEPAGE="https://www.elastic.co/products/beats"
SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="test"

DEPEND=">=dev-lang/go-1.11.2"
RDEPEND="!app-admin/filebeat-bin"

# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'

S="${WORKDIR}/src/github.com/elastic/beats"

src_unpack() {
mkdir -p "${S%/*}" || die
default
mv beats-${PV} "${S}" || die
}

src_prepare() {
default

# avoid Elastic license
rm -r x-pack || die

# use ${PV} instead of git commit id
sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
}

src_compile() {
GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
}

src_install() {
keepdir /var/{lib,log}/${PN}

fperms 0750 /var/{lib,log}/${PN}

newconfd "${FILESDIR}/${PN}.confd" ${PN}
newinitd "${FILESDIR}/${PN}.initd.1" ${PN}

docinto examples
dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}

dobin filebeat/filebeat
}

pkg_postinst() {
if [[ -n "${REPLACING_VERSIONS}" ]]; then
elog "Please read the migration guide at:"
elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
elog ""
fi

elog "Example configurations:"
elog "${EROOT}/usr/share/doc/${PF}/examples"
}

0 comments on commit 7b14583

Please sign in to comment.