forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/pytest-httpserver: Bump to 1.0.11
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST pytest_httpserver-1.0.10.tar.gz 60446 BLAKE2B 99d1db58f7b6fab78b687db0fc2448cbd9a3132b999e4d0ca1c8533ec2afebc717b9c28a16635260fb305aaafb832f591d28752ba3930473312a677dfaffd0be SHA512 f8636ccf757f687666a5336db66ac061ea6205979c7bbf8c9a2534282d8559453a7470318c07384aa755282c12e63537cce2ab9e9f3b2fbcda0e649ed2a45f92 | ||
DIST pytest_httpserver-1.0.11.tar.gz 66742 BLAKE2B 641c566b2ae349bf02f9a457c488ac6820cbeabbf430d12d84ba02b09382947aa60b61a6a1578b260d160b3e8d01c37745dfd2e90bdb6aea40f546a8103b367f SHA512 3d3055bc48bbe523fddbf9e9ba3495c3141a6dcd4f8b2cf9c19f11d1e6f4a93eebe64bb920ea5bd3bc0d30f4469ecb9a8beca35fc844ca2c62f6868edcb570ee |
43 changes: 43 additions & 0 deletions
43
dev-python/pytest-httpserver/pytest-httpserver-1.0.11.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=poetry | ||
PYTHON_COMPAT=( python3_{10..13} pypy3 ) | ||
|
||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="HTTP server for pytest to test HTTP clients" | ||
HOMEPAGE=" | ||
https://github.com/csernazs/pytest-httpserver/ | ||
https://pypi.org/project/pytest_httpserver/ | ||
" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86" | ||
|
||
RDEPEND=" | ||
dev-python/werkzeug[${PYTHON_USEDEP}] | ||
" | ||
BDEPEND=" | ||
test? ( | ||
dev-python/requests[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
python_test() { | ||
local EPYTEST_DESELECT=( | ||
# confused by extra compressors available (for Accept-Encoding) | ||
tests/test_log_querying.py::test_verify_assert_msg | ||
) | ||
local EPYTEST_IGNORE=( | ||
# tests from building release artifacts | ||
tests/test_release.py | ||
) | ||
|
||
epytest -p no:localserver | ||
} |