Skip to content

Commit

Permalink
media-libs/kvazaar: update live ebuild and bump to 0.8.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Jan 18, 2016
1 parent 2f6e525 commit 7b4560e
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 22 deletions.
1 change: 1 addition & 0 deletions media-libs/kvazaar/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST kvazaar-0.7.1.tar.gz 288339 SHA256 c3693f801f0e717b1dcab3494d3e18a1687861af1a2c33b8878b2f70bcf18164 SHA512 a7d0a68e4b898f7dbb4175ab8a005d88786f522e185c1814a36a48395d34398880fc18e6baeebe4fef0ea97829e937df2ec9f547e05a9a1b2fdb74e260390e2a WHIRLPOOL ad640f5cf4c8238c7fbda3d126e1d7d37b3619a3eb000737eabf75b464fbf37cbc1de11c643725fb8cfbbfe8aa21df12d2c7b7aed0df29f7d8774256e78818a0
DIST kvazaar-0.7.2.tar.gz 293147 SHA256 623e955d1dbf4f469a57c540537e977f3cead2abcb43d640e2fa0f568168cede SHA512 db06bed953cbe69f2388adfeeecdd150f36a436199e9627a06c26e4fee740255d47757522a3216c2aaca6233fbff0bf64ab5fa6ac6a26cf5af88bfd07c7d78a0 WHIRLPOOL 371379ed6c30c6db3c729e0cfded3f300157a62255b9865f4f45666354f1e2e35cad2e869600de662745251f044f7852dcb8e08e820f4d41f3e7efea13ccb645
DIST kvazaar-0.8.2.tar.gz 422425 SHA256 1b9354a639ab6c902e974780b39112b5e75477205611f88b54562c895182b945 SHA512 e5089ae28b467c19e854dcf53ac48d14aa01b5f6a72d7a11e66e146c7b9cc11068377a9021f03a697dcf66a66dd42180d2bab24d62c00ee4e2763c5d93754a85 WHIRLPOOL 54c9de8df2b35a2192ba56680d7edc047b1cccc0682875b5a5f6dacec5e67daf8137576d4fc9f86139a54ce82dd29355cfce3fd66589961eb09fe329f64dd15c
51 changes: 51 additions & 0 deletions media-libs/kvazaar/kvazaar-0.8.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

SCM=""

if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
fi

inherit multilib autotools multilib-minimal toolchain-funcs ${SCM}

DESCRIPTION="An open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"

if [ "${PV#9999}" = "${PV}" ] ; then
SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="LGPL-2.1"
# subslot = libkvazaar major
SLOT="0/3"
IUSE="cpu_flags_x86_avx2 static-libs"

DEPEND=""
RDEPEND="${DEPEND}"

ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="${DEPEND}
abi_x86_32? ( ${ASM_DEP} )
abi_x86_64? ( ${ASM_DEP} )"

src_prepare() {
eautoreconf
}

multilib_src_compile() {
ECONF_SOURCE="${S}" \
econf \
--docdir "/usr/share/doc/${PF}" \
$(use_enable static-libs static) \
$(use_enable cpu_flags_x86_avx2 asm)
}

multilib_src_install_all() {
find "${ED}" -name '*.la' -delete
}
32 changes: 10 additions & 22 deletions media-libs/kvazaar/kvazaar-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
fi

inherit multilib multilib-minimal toolchain-funcs ${SCM}
inherit multilib autotools multilib-minimal toolchain-funcs ${SCM}

DESCRIPTION="An open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
Expand All @@ -22,42 +22,30 @@ if [ "${PV#9999}" = "${PV}" ] ; then
fi

LICENSE="LGPL-2.1"
SLOT="0"
# subslot = libkvazaar major
SLOT="0/3"
IUSE="cpu_flags_x86_avx2 static-libs"

DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}/src"

ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="${DEPEND}
abi_x86_32? ( ${ASM_DEP} )
abi_x86_64? ( ${ASM_DEP} )"

src_prepare() {
multilib_copy_sources
eautoreconf
}

multilib_src_compile() {
tc-export CC
emake \
ARCH="${CHOST%%-*}" \
$(usex cpu_flags_x86_avx2 "" "KVZ_DISABLE_AVX2=true") \
lib-shared \
$(usex static-libs "lib-static" "") \
$(multilib_is_native_abi && echo cli)
}

multilib_src_install() {
emake \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
install-pc install-lib \
$(usex static-libs "install-static" "") \
$(multilib_is_native_abi && echo install-prog)
ECONF_SOURCE="${S}" \
econf \
--docdir "/usr/share/doc/${PF}" \
$(use_enable static-libs static) \
$(use_enable cpu_flags_x86_avx2 asm)
}

multilib_src_install_all() {
dodoc "${WORKDIR}/${P}/README.md" "${WORKDIR}/${P}/CREDITS" "${WORKDIR}/${P}/doc/"*.txt
find "${ED}" -name '*.la' -delete
}

0 comments on commit 7b4560e

Please sign in to comment.