Skip to content

Commit

Permalink
games-emulation/mgba: Bump to version 0.7.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Feb 26, 2019
1 parent 87abfbf commit 7b9b629
Show file tree
Hide file tree
Showing 2 changed files with 119 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mgba/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mgba-0.6.3.tar.gz 7442154 BLAKE2B 2b46cf36174ef0a186b1bc71784820e6ddd7754a7cae695a95dcdae96efff58af70dd14faa2f1f6194a23450943d82aed2394f7bf2821ed91bf558eef6ae9c4d SHA512 d646af7869dbcf8df671a75ecfd8c270950c013b826b23b94bacae43a77243786f198725e1b9bf17827d1ffcf6a8eef70091d53ea878bfb2450472485f42f233
DIST mgba-0.7.0.tar.gz 10767992 BLAKE2B 75ffd02443f95eba2f82a0f6d2171263bfc7fa3c2c57d246e852964ed52a9cd3c6fc08d39ad349fd6b9cef189feb25d1d9efdcc4b000d07a96d0cf4cbd5cb34f SHA512 68eac18f6e411c60ef6c6dded0f2b293cb4831c4c6f15c4cf3bb7f8dc6a5de65000d7d904ff5bec52aef8714fae3a77d7ed7b43cbccba528cc05b56546802010
DIST mgba-0.7.1.tar.gz 11054044 BLAKE2B 910d6ddfbbe1680b07cee519ff27814401093a9a157bea516e55a4881561b5d67992af6274b2a4e431ace879cfce04d58eb9eae243b26c50d94f1ab3ec591cb7 SHA512 91aa66a9140e250ccd6f4790c2ed4977248bccda3b499bd48c61b01aedbdd93e947f5505dee7c30b21beb39723fc321cdbdb6953df8292a193e0fbb9161a8ae5
118 changes: 118 additions & 0 deletions games-emulation/mgba/mgba-0.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,118 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils desktop xdg

DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug elf ffmpeg imagemagick libav opengl qt5 +sdl sqlite"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"

RDEPEND="
media-libs/libpng:0=
sys-libs/zlib[minizip]
elf? ( dev-libs/elfutils )
ffmpeg? (
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:= )
)
imagemagick? ( media-gfx/imagemagick:= )
opengl? ( virtual/opengl )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtwidgets:5
opengl? ( dev-qt/qtopengl:5 )
)
sdl? ( media-libs/libsdl2[X,sound,joystick,video,opengl?] )
sqlite? ( dev-db/sqlite:3 )
"
DEPEND="${RDEPEND}"

src_prepare() {
xdg_environment_reset
cmake-utils_src_prepare

# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
rm -r src/third-party/${pkg} || die
done
}

src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DBUILD_GL="$(usex opengl)"
-DBUILD_PYTHON=OFF
-DBUILD_QT="$(usex qt5)"
-DBUILD_SDL="$(usex sdl)"
-DBUILD_SHARED=ON
# test suite fails to build (>=0.6.0)
-DBUILD_SUITE=OFF
-DBUILD_TEST=OFF
-DM_CORE_GB=ON
-DM_CORE_GBA=ON
-DUSE_DEBUGGERS="$(usex debug)"
-DUSE_EDITLINE="$(usex debug)"
-DUSE_ELF="$(usex elf)"
-DUSE_EPOXY=OFF
-DUSE_FFMPEG="$(usex ffmpeg)"
-DUSE_GDB_STUB="$(usex debug)"
-DUSE_LIBZIP=OFF
-DUSE_LZMA=OFF
-DUSE_MAGICK="$(usex imagemagick)"
-DUSE_MINIZIP=ON
-DUSE_PNG=ON
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
if use qt5 ; then
dobin ../${P}_build/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
newicon -s ${size} res/${PN}-${size}.png ${PN}.png
done
fi
if use sdl ; then
doman doc/${PN}.6
newbin ../${P}_build/sdl/${PN} ${PN}-sdl
fi

dolib.so ../${P}_build/lib${PN}.so*
}

pkg_preinst() {
if use qt5 ; then
xdg_pkg_preinst
fi
}

pkg_postinst() {
if use qt5 ; then
xdg_pkg_postinst
fi
}

pkg_postrm() {
if use qt5 ; then
xdg_pkg_postrm
fi
}

0 comments on commit 7b9b629

Please sign in to comment.