forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.28
- Loading branch information
Michael Sterrett
committed
Jun 21, 2016
1 parent
0274bed
commit 7bc0194
Showing
3 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST vor-0.5.5.tar.bz2 239291 SHA256 ead1b9786741e26d37ff7c5185b7fe1e91f90f76ebed3785225312e323b7c7da SHA512 a4de43699b78adfe28bbd773cd9f9d1e3ee50b51b4e1848ff1baf836f6242d8391a304445994ca669eab13acbd2dd3ae49f0665bdb07d19c7a1674e0dde9bfbd WHIRLPOOL d0a63aa4b0c42e234593ed9ba09017ef3ab1a00de8ba8580dffefcd88ea0d09c8bc4e1d7edf6ef10cee319d1c17db9fef024aa6ffb495462cc97bf90ad8dbc46 | ||
DIST vor-0.5.7.tgz 358032 SHA256 f3411f747fa998d9ae13b5636ecb478a2bd9abc804030f8440c878bd2c6f8f09 SHA512 32dbfe95971298f9f0191cc95fdb5e9ec34c5f6771df1566554b128644770bfba618df3aac7242e647c8af2f41fc59c9e5620a4c56932d3af72197f6a19f0bce WHIRLPOOL 00cc37d1b911f39e8826f3af323e061d8d2744b64015410f96da4ff74497c4798d24f58cafc4e70c6bad10eb4e2c715726ca3d1666c0a3c27c004667a1002eea |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
--- Makefile.in | ||
+++ Makefile.in | ||
@@ -43,7 +43,7 @@ | ||
SDL_CFLAGS := @SDL_CFLAGS@ | ||
SDL_LIBS := @SDL_LIBS@ | ||
|
||
-ldflags := $(SDL_LIBS) -lSDL_image -lSDL_mixer $(LDFLAGS) | ||
+ldflags := $(LIBS) $(SDL_LIBS) $(LDFLAGS) | ||
cflags := -I. $(SDL_CFLAGS) $(paths) $(CFLAGS) | ||
|
||
my_objects := args.@OBJEXT@ dust.@OBJEXT@ file.@OBJEXT@ mt.@OBJEXT@ rocks.@OBJEXT@ score.@OBJEXT@ sprite.@OBJEXT@ sound.@OBJEXT@ autopilot.@OBJEXT@ | ||
|
||
--- configure.ac | ||
+++ configure.ac | ||
@@ -12,6 +12,11 @@ | ||
AC_PROG_MAKE_SET | ||
|
||
# Checks for libraries. | ||
+dnl Check for libm for sqrt() | ||
+AC_SEARCH_LIBS([sqrt], [m], [], [ | ||
+ AC_MSG_ERROR([unable to find the sqrt() function]) | ||
+]) | ||
+ | ||
AC_CHECK_LIB([SDL_image], [IMG_LoadPNG_RW]) | ||
AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio]) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit eutils gnome2-utils games | ||
|
||
DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die" | ||
HOMEPAGE="http://jasonwoof.org/vor" | ||
SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
DEPEND="media-libs/libsdl[sound,video] | ||
media-libs/sdl-image[png] | ||
media-libs/sdl-mixer[mod]" | ||
RDEPEND=${DEPEND} | ||
|
||
src_install() { | ||
dodir "${GAMES_BINDIR}" | ||
DOCS="README* todo" default | ||
newicon -s 48 data/icon.png ${PN}.png | ||
make_desktop_entry ${PN} VoR | ||
prepgamesdirs | ||
} | ||
|
||
pkg_preinst() { | ||
games_pkg_preinst | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |