Skip to content

Commit

Permalink
app-xemacs/ebuild-mode: add 1.73
Browse files Browse the repository at this point in the history
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
ulm committed Aug 15, 2024
1 parent c3ccd2e commit 7bf223b
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-xemacs/ebuild-mode/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.71.tar.xz 41592 BLAKE2B 82f10340f619ea5689ae769f63818be1ac45a7bad65ac0f88ae1f92a3e7e6435286f66fd0da160a98647a610dde6dd79afb1655518823972c462e93c5437a74c SHA512 2a8f0c715102d49d69941efadb2a0f1d2e982660221d2c8742903fd16b8c394113f2a7ca9c2e147836a59887ead98d8776f575f61e66dcf3700b764050345ec6
DIST ebuild-mode-1.72.tar.xz 41968 BLAKE2B 24170aa6f23022f47707445eebbb7272c898fa8ca922d0a1ee57962ccc9feed6ea608661998e3f812a0b5fcc8ce8d8ff0baa890505dad846e0dc4b5c9e0b4236 SHA512 7f2234f9f5053f9588fb25d673dbce10a9d6e5c056ea7dabf04ffe5a0f8da7064b81829229339c5d98ee7ce840eb6c8b9ec24fcfd3dee2d5b798b5e6adb81e10
DIST ebuild-mode-1.73.tar.xz 45264 BLAKE2B 115f67f9bfbf80ce5ddda1cc1dfee62aec15cb66c694b634361762c47c8c5afa6cdf0bc6c374440e939accbe9b13df0a84a7957b8c8c72a13324d2544388124a SHA512 855fdd0c94da77bae8f948fbc02782d47a0982e4a3d8ccff5d77a9c6b1f55b80a78144b493e5949e04b196cf8ee95e1fcc0b84c6ecace1a7d687ed6733d25820
46 changes: 46 additions & 0 deletions app-xemacs/ebuild-mode/ebuild-mode-1.73.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit optfeature

DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"

RDEPEND=">=app-editors/xemacs-21.4.20-r5
app-xemacs/sh-script"
BDEPEND="${RDEPEND}"

src_compile() {
local XEMACS="${EPREFIX}/usr/bin/xemacs"

"${XEMACS}" -batch -q --no-site-file \
-eval "(add-to-list 'load-path nil)" \
-f batch-byte-compile \
ebuild-mode.el gentoo-newsitem-mode.el || die

"${XEMACS}" -batch -q --no-site-file \
-eval "(setq autoload-package-name \"${PN}\")" \
-eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
-l autoload -f batch-update-autoloads \
ebuild-mode.el gentoo-newsitem-mode.el || die
}

src_test() { :; } # ERT is not yet available for XEmacs

src_install() {
insinto /usr/share/xemacs/site-packages/lisp/${PN}
doins *.el *.elc
}

pkg_postinst() {
optfeature "ebuild commands support" sys-apps/portage
optfeature "additional development tools" dev-util/pkgdev
optfeature "ebuild QA utilities" dev-util/pkgcheck
}

0 comments on commit 7bf223b

Please sign in to comment.