Skip to content

Commit

Permalink
dev-python/jupyter-server: Bump to 2.10.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 13, 2023
1 parent cdc182d commit 7c1b230
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/jupyter-server/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST jupyter_server-2.10.0.tar.gz 709151 BLAKE2B 6b5c41d00efbe06e47f1ee9146cfd5670774be84982fc24ed7c27bc420c9a9667ff193d272670fdd7d0a0b2dc1414fa271c0b08e2eeddd3dc08dc901e93594aa SHA512 8238dca7314303ffcf8424f9c997d68c06fc4cf05128146ffe0d3ce495b4c2a8cf260858da8ec0ceb138f0b6789f57fc740b0c5a0bdb977c1311460def0fbf8a
DIST jupyter_server-2.7.3.tar.gz 705798 BLAKE2B d5655968f17b2a5536539858769124650f41985d5d99b782e70d99140a7e61820b913b525fc10041a56b6946ec4feb7e05015a10970786d024628e8c840fae94 SHA512 ad9be38208ef4196417561355a62889e34d657f3114b710f13f974f4b453b465b7d473ced46eba873ee980d631d2648e0d4b29267011ed444247a33325f959e9
DIST jupyter_server-2.8.0.tar.gz 708394 BLAKE2B 2beaba510b0e841203c58316db8507c8c503fdeacfbe7de1287d1ecf0740334c02b430ad7111043e21da45669cc1bd13bb313b5cd45f999490fa07c9057b1bea SHA512 e2ec60994737a9979545aaba3de1f846eb68c809cb952bfba6ce22c061f1e644a712f4b7b069ebfc393e8dd7a7bf723b2c3530a7a1b103eb1dbf42a60a59e6e6
DIST jupyter_server-2.9.0.tar.gz 709038 BLAKE2B 68569f323087c55427d2d0b5fe7df55082809a76b25102cf08f62393c1c943bf5527ed461e392f45751f6c4182fd6423056d3719aed6681cd85ca2f4e7fca0b7 SHA512 5d695f72cc02c73345a811739e2a7006313d37b5c05894b5da7792b0174537bfe962456d996605abc4f8ec2a4e1337b1d5817b667b4b5708c599e1a96452d597
Expand Down
74 changes: 74 additions & 0 deletions dev-python/jupyter-server/jupyter-server-2.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{10..12} )

inherit distutils-r1 pypi

DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
HOMEPAGE="
https://jupyter.org/
https://github.com/jupyter-server/jupyter_server/
https://pypi.org/project/jupyter-server/
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

RDEPEND="
>=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
dev-python/argon2-cffi[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
>=dev-python/jupyter-client-7.4.4[${PYTHON_USEDEP}]
>=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
>=dev-python/jupyter-events-0.6.0[${PYTHON_USEDEP}]
>=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
>=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
dev-python/overrides[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/prometheus-client[${PYTHON_USEDEP}]
>=dev-python/pyzmq-24[${PYTHON_USEDEP}]
>=dev-python/send2trash-1.8.2[${PYTHON_USEDEP}]
>=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
>=dev-python/tornado-6.2[${PYTHON_USEDEP}]
>=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
dev-python/websocket-client[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
dev-python/pytest-jupyter[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/pytest-tornasync[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

python_test() {
local EPYTEST_DESELECT=(
# This fails if your terminal is zsh (and maybe other non-bash as well?)
tests/test_terminal.py
# Fails because above is ignored
tests/auth/test_authorizer.py
# Fails with additional extensions installed
tests/extension/test_app.py::test_stop_extension
)

# FIXME: tests seem to be affected by previously installed version
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest \
-p pytest_tornasync.plugin \
-p jupyter_server.pytest_plugin \
-p pytest_console_scripts \
-p pytest_timeout
}

0 comments on commit 7c1b230

Please sign in to comment.