Skip to content

Commit

Permalink
dev-python/oslo-privsep: 1.22.0 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
prometheanfire committed Aug 28, 2017
1 parent a20be8b commit 7c3bfcd
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-privsep/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST oslo.privsep-1.16.0.tar.gz 30448 SHA256 bffc4ea46cf6e19c84dbc16f3b1fc7a78fae2480c7609bc97e054a88af7d6773 SHA512 223cb4a32a9a8545833621c7a6e3a9ab5acf84a188f2a6f45df4311e02ec64cef8d7150ddde89ca3c207f5aee599ed655b1f9a5fbdec7f55605d4d3aa251edd5 WHIRLPOOL d6666f7326d83dd64e418b433c0064bbf239c77a09aaaf378e6188f75d5d9ed75114f3eb285c203f1cf816bbe1c7e21f631b74ecbea033a196e7581169c2afca
DIST oslo.privsep-1.22.0.tar.gz 33179 SHA256 cf088141fd2067afd9549b05adc9744287768d03da4879afafe8cb71253a2029 SHA512 ba4bb9b4fae1dae029a72f1216c23eb7c3ec0d9376c6c1b6ac864b56d3a942e4774ef95830f451c6d2c11cac5089bbca3c7c1cc47f7efd9dc5be58a3bcdf76e5 WHIRLPOOL 4754e89c59f99aca7897cb16076bd49c8cda5f78c761a719dbcb85fda7e3e968650437ea1c6cc9a869a2e2774f4d5b82999bd66181e217302c1f93d987031b64
54 changes: 54 additions & 0 deletions dev-python/oslo-privsep/oslo-privsep-1.22.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="OpenStack library for privilege separation."
HOMEPAGE="https://pypi.python.org/pypi/oslo.privsep"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.privsep/oslo.privsep-${PV}.tar.gz"
S="${WORKDIR}/oslo.privsep-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="test"

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
>=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
>=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
!~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND="
>=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
!~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
!~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
!~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
dev-python/cffi[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
<dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
>=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

# python_test() {
# }

0 comments on commit 7c3bfcd

Please sign in to comment.