Skip to content

Commit

Permalink
dev-libs/device-atlas-api-c: Version bump
Browse files Browse the repository at this point in the history
Closes: gentoo#6784
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
bjacquin authored and mgorny committed Jan 21, 2018
1 parent 2014e78 commit 7c52fa4
Show file tree
Hide file tree
Showing 3 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/device-atlas-api-c/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST deviceatlas-enterprise-c-2.1.2_1.tgz 184432 SHA256 984e1ae3147459a4ed0a8d5053d83dd05ce8c5127cd3cb055be35a74e9217372 SHA512 4ff269c55e74688dc1c954a1d9b0fc28aa135eccd20089f4da390522644bd1c08e2bc38e4ad15a64308a0e91b007a820dcdc3998c262fa5a7cfe1038e9f0e969 WHIRLPOOL 73c1c7eec0daed7632e8a5a7ceda956ec91cc603fe45df2fdbf2b54ecc950bd72ff59fdd85ff6a0ee70d54b2099ecc3219ef55f4aecb308f254851f93fe57738
DIST deviceatlas-enterprise-c-2.1.2_2.tgz 184368 SHA256 feaa9198a5d6bed125b34742bd626ad0a0fcb862803916cd7d974413f8bdfdce SHA512 46c021b3430c6900f9172c13cdeb26931634345485c2fe0fe7b6911f7c6f6bee46ab3551e4fe11ef5b5caabe66c786c72b51db6875aa9d44aab673056b9debee WHIRLPOOL d85161010cf195eab5ef9c4e83404ad08cc10d607ace5bc6424ffb170ca09a26d5410534279eab1d721615db943f3a447ff908f62f76311ec80c3d95abbb49d4
DIST deviceatlas-enterprise-c-2.1.3.tgz 183663 BLAKE2B e190aa8e9a4b9bc90af76e21eb425c0f040ef70e605c8f9e588bd0c859520a82807aaafddd24402d3365e94bcf3b7a875a65804f2b1b3bed6f0703f28a841440 SHA512 364811d42b2c0d937a12f2bbfee760701a1dee4e93bcc84423c8b236d59257a3440111ffc6072a7822b9694ea65986572550f67d0b1e5d68a784d1339b2b70aa
DIST deviceatlas-enterprise-c-2.1.zip 504286 SHA256 a02fc29486d245b1c8d946c663b71ba981e88fee8d037f5bc1bf255deb287974 SHA512 99a8e89f3d1c084a93b184685108ea65d1fd925e0c8b52599a42dbe70af3126103da0a9fd284b14ddf59b996204334d360a12651025413bc4d7f76054779275b WHIRLPOOL 939733a58f352cbeee852ccfea3f2f022310ceb7363a15889d9a6366532102ee700271b6008e0a57ae4d86cafe6354409f9520105e46eaabb5c41f1a7827f1b4
50 changes: 50 additions & 0 deletions dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit cmake-multilib

MY_P="deviceatlas-enterprise-c-${PV/_p/_}"

DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
HOMEPAGE="https://deviceatlas.com"
SRC_URI="${MY_P}.tgz"

LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="doc examples"

RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
DEPEND="
${RDEPEND}"

RESTRICT="fetch mirror bindist"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}/${PV}-src-cmakelists.patch"
)

pkg_nofetch() {
eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
eerror "And download DeviceAtlas C API"
eerror "Then place the file in ${DISTDIR}/${MY_P}.tgz"
}

multilib_src_install_all() {
if use doc; then
local -a HTML_DOCS=( Documentation )
fi

if use examples; then
docinto examples
dodoc Examples/daexutil.h
dodoc Examples/example{0,1,2,3,4}.c
dodoc Examples/util.c
dodoc Examples/EXAMPLES.USAGE
fi

einstalldocs
}
18 changes: 18 additions & 0 deletions dev-libs/device-atlas-api-c/files/2.1.3-src-cmakelists.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
--- a/Src/CMakeLists.txt
+++ b/Src/CMakeLists.txt
@@ -18,6 +18,7 @@ if (NOT MODEL)
set(MODEL 64)
endif()

+include(GNUInstallDirs)
message(STATUS "${CMAKE_BUILD_TYPE} version")

include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
@@ -37,5 +38,5 @@ set (CMAKE_EXE_LINKER_FLAGS -m32)
set (CMAKE_SHARED_LINKER_FLAGS -m32)
endif()

-install(FILES libda.so libda.so.${API_VERSION} DESTINATION /usr/local/lib)
-install(FILES dac.h dac_json.h DESTINATION /usr/local/include)
+install(TARGETS da DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install(FILES dac.h dac_json.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})

0 comments on commit 7c52fa4

Please sign in to comment.