Skip to content

Commit

Permalink
media-libs/rubberband: fix prefix support and switch to eapi 7
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/660592
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
nado authored and prometheanfire committed Jul 12, 2018
1 parent 6d0bfbc commit 7c6ee74
Showing 1 changed file with 46 additions and 0 deletions.
46 changes: 46 additions & 0 deletions media-libs/rubberband/rubberband-1.8.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit multilib multilib-minimal

DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
HOMEPAGE="https://www.breakfastquay.com/rubberband/"
SRC_URI="https://code.breakfastquay.com/attachments/download/34/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="static-libs"

RDEPEND="media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}]
media-libs/libsamplerate[${MULTILIB_USEDEP}]
media-libs/libsndfile
media-libs/ladspa-sdk
sci-libs/fftw:3.0[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
if ! use static-libs ; then
sed -e '/^all:/s/$(STATIC_TARGET)//' \
-e '/^\tcp $(STATIC_TARGET)/d' \
-i Makefile.in || die
fi
multilib_copy_sources
}

multilib_src_install() {
emake INSTALL_BINDIR="${ED}/usr/bin" \
INSTALL_INCDIR="${ED}/usr/include/rubberband" \
INSTALL_LIBDIR="${ED}/usr/$(get_libdir)" \
INSTALL_VAMPDIR="${ED}/usr/$(get_libdir)/vamp" \
INSTALL_LADSPADIR="${ED}/usr/$(get_libdir)/ladspa" \
INSTALL_LRDFDIR="${ED}/usr/share/ladspa/rdf" \
INSTALL_PKGDIR="${ED}/usr/$(get_libdir)/pkgconfig" \
install
}

multilib_src_install_all() {
dodoc CHANGELOG README.txt
}

0 comments on commit 7c6ee74

Please sign in to comment.