Skip to content

Commit

Permalink
app-crypt/loop-aes-losetup: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
alonbl committed Dec 23, 2015
1 parent be2a023 commit 7ccec8d
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-crypt/loop-aes-losetup/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST util-linux-2.21-20120228.diff.bz2 43809 SHA256 fc28d4f0e2737b53a4db59072ab0fcf4180a8ece28c79219a21780124798572a SHA512 94135ed18699efd949f5937576da2721957177bbef9be8234ae48ee34f30f4cb65361a541f79c636ed6d6bb5c2786e1096d096407834e1421d82ee78ae0790e9 WHIRLPOOL ba23dccc56fc49d7ad9075537317ad4580ace2a4cd8f6b0250f42035c03ba910f3cafa8e8b1da4c7e5a0960d74c42f2706fda579a3b4a6cadc61dccd2fff3ff0
DIST util-linux-2.21.tar.xz 2954504 SHA256 5192e8ba7dcf3cf0dc447f07b3d177f6cb3fb49dfae54ac45d6c8c7d86eeab0f SHA512 aab384db2d1a3e08fd560a3e4d7ed7d6b2ceac61386db94eecae65bd540200a8549e141b99d8dad5c6f96587940b574d0544984acef6a35d1f24870e0072c552 WHIRLPOOL 1968ddd63fd21ef9542bb8afc77292ed2bad6f83e1cd67aa4159db8b320abd80ee0d20a062df35ae2ad91e0bc9068168b9f9e44aa39eaf4861d436dd855bea5d
DIST util-linux-2.26-20150310.diff.bz2 41017 SHA256 18d88810d5d6e95313c23162566bcf7e1a7b785bed5dd395127c144127c9e9ef SHA512 c8e7d7a4795d2ed75af5e0513c19510ca649682df86655ecabe1563586bdb46f32bb9abd6cfb09df230f935cfa396e0d63b1545a40a5f4ce47524a82e7dd7ca6 WHIRLPOOL 2ca00b9ec52b64ce1e083b9a706003d1f0445fb5d7f391e28b698c684dba5cb8bc2a590565dcc23ac6527b8099838435b86e7a78097ab8a19491fe14b6c50ca6
DIST util-linux-2.26.tar.xz 3847960 SHA256 a23c6f39dea0ed215ccd589509ffc7bb6f706f6e1a04760f493fb0fd7e93c489 SHA512 af07d49a433fce683da7bdf9aea5693ad108aa16166e0147716175bd779fe5090029617dd7db153bc0f5efcf7bdd377761a616efd4cca90a87bf317132ede88c WHIRLPOOL 4f7c9463bfe1523819671824de26e051c496c86884ca34b25208762179345c799fe61e566228ebfcbca2f2b63163539e37b06e438a58f562cf7b53f954564150
74 changes: 74 additions & 0 deletions app-crypt/loop-aes-losetup/loop-aes-losetup-2.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils toolchain-funcs flag-o-matic

MY_PV="${PV/_/-}"
MY_P="util-linux-${MY_PV}"
LOOPAES_PV="${PV}-20150310"
S="${WORKDIR}/${MY_P}"

DESCRIPTION="Various useful Linux utilities"
HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
http://loop-aes.sourceforge.net/updates/util-linux-${LOOPAES_PV}.diff.bz2"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"

LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
IUSE="nls selinux static"

RDEPEND="selinux? ( sys-libs/libselinux )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
virtual/os-headers"

src_prepare() {
epatch "${WORKDIR}"/util-linux-*.diff
elibtoolize
}

lfs_fallocate_test() {
# Make sure we can use fallocate with LFS #300307
cat <<-EOF > "${T}"/fallocate.${ABI}.c
#define _GNU_SOURCE
#include <fcntl.h>
main() { return fallocate(0, 0, 0, 0); }
EOF
append-lfs-flags
$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
|| export ac_cv_func_fallocate=no
rm -f "${T}"/fallocate.${ABI}.c
}

src_configure() {
lfs_fallocate_test
# The scanf test in a run-time test which fails while cross-compiling.
# Blindly assume a POSIX setup since we require libmount, and libmount
# itself fails when the scanf test fails. #531856
tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
# We manually set --libdir to the default since on prefix, econf will set it to
# a value which the configure script does not recognize. This makes it set the
# usrlib_execdir to a bad value. bug #518898#c2, fixed upstream for >2.25
ECONF_SOURCE=${S} \
econf \
--libdir='${prefix}/'"$(get_libdir)" \
--disable-all-programs \
--enable-libsmartcols \
--enable-losetup \
--without-ncurses \
--without-udev \
$(use_enable nls) \
$(use_with selinux) \
$(tc-has-tls || echo --disable-tls) \
$(use static && echo --enable-static-programs=losetup)
}

src_install() {
emake install DESTDIR="${T}/root"
newsbin "${T}/root/sbin/losetup" loop-aes-losetup
use static && newsbin "${T}/root/bin/losetup.static" loop-aes-losetup.static
}

0 comments on commit 7ccec8d

Please sign in to comment.