Skip to content

Commit

Permalink
dev-python/hypothesis: Bump to 4.47.4
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 28, 2019
1 parent 538d134 commit 7cd3de5
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/hypothesis/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad258
DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d91eda525f8ef51eb893f1f8e5224cead8572f3c06f6a4bb345c123e56ed06d0676c85dc4477a80e54480baa6bd9f5f2bc069e SHA512 bebc5da337fa74a75d08cb57531c2f6b8ba1ab16d1a3d9be8348cd56ada1ab25a34e3b812a4aa71bf172bc97ebc8df0accdad37466f9162c3f8f2a8edbea9da9
DIST hypothesis-python-4.47.1.tar.gz 3253826 BLAKE2B 6daae1eef6c36b874f44d1e3c7a4ebd18e76c6a4d1543062cc53bbb93d65e1e0a441b084c97cb13f79867e4e77830c2ce71ef779f7086fdfb99756226911d81b SHA512 e3de34822b018a3d7ef474a90eff6b74ce3f214e374cadec34af80b8bdea90bcbc4f8e3de6cac9218729d99e8ffa12dd8216a53078801ba45b76552fac2a6c35
DIST hypothesis-python-4.47.3.tar.gz 3254272 BLAKE2B 6f9b134b77cfc1e72012992c7b352d3cd52c503f1607f88638b54c9258fd80ff02c153231cda9cb81314580e79abcc749b285787d147fa0a7344ee077b5bad9f SHA512 1bb2737f505169d361350d63b09e66874b8d82f0363911cf6b7a73819629d71f62ebfba6d1f1129b6fc76588feb8bf171b6106d6209527d60694cc6268212137
DIST hypothesis-python-4.47.4.tar.gz 3253968 BLAKE2B 94c0e6738a5e9cc852e8315023497ae7e067f5bc1ff9d501713e8ba4bc23e9b16535ec349a59a8bc9d44353f55a00eb71cc6dc55bf761ba585b88b5257c8e64e SHA512 8f78a2afd04402a8f4fb0a97c2f3e33ce42b85e5a3bd2965451d1310398856b61abafb0ad070192ed968a1f748f0182842d299bdae86888396fd58545ba03699
58 changes: 58 additions & 0 deletions dev-python/hypothesis/hypothesis-4.47.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="threads(+),sqlite"

inherit distutils-r1 eutils

DESCRIPTION="A library for property based testing"
HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
>=dev-python/pytest-4.3[${PYTHON_USEDEP}]
!!<dev-python/typing-3.7.4.1
)
"

S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"

src_prepare() {
# avoid pytest-xdist dep for one test
sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
tests/pytest/test_statistics.py || die
distutils-r1_src_prepare
}

python_test() {
local pyver=$(python_is_python3 && echo 3 || echo 2)
pytest -vv tests/cover tests/pytest tests/py${pyver} ||
die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
optfeature "datetime support" dev-python/pytz
optfeature "dateutil support" dev-python/python-dateutil
optfeature "numpy support" dev-python/numpy
optfeature "django support" dev-python/django dev-python/pytz
optfeature "pandas support" dev-python/pandas
optfeature "pytest support" dev-python/pytest
}

0 comments on commit 7cd3de5

Please sign in to comment.