Skip to content

Commit

Permalink
app-metrics/vault_exporter: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Manuel Rüger <[email protected]>
  • Loading branch information
mrueg committed Jan 11, 2019
1 parent b4c99f8 commit 7ce7ecd
Show file tree
Hide file tree
Showing 5 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/vault_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST vault_exporter-0.1.2.tar.gz 34555506 BLAKE2B 53178f8a16fceca442e38a756081cca438abdd786960de3dae073f3ce5f2ac2c5d06684ec56e48a2057b4a2161a25527b41c36d3705a054f0bae37357f33faee SHA512 71941c17d7146861a09ed48289efe15143d3fba18e56accdfdf977bf4443bb650e7201a4870b63793d372dcca8f53a04131c12803f019efbdcac9e0ca8909cbd
2 changes: 2 additions & 0 deletions app-metrics/vault_exporter/files/vault_exporter.confd
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
# arguments for prometheus vault exporter
command_args=""
19 changes: 19 additions & 0 deletions app-metrics/vault_exporter/files/vault_exporter.initd
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
#!/sbin/openrc-run
# Copyright 2016-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

description="Prometheus Vault exporter"
pidfile=${pidfile:-"/run/${RC_SVCNAME}.pid"}
user=${user:-${RC_SVCNAME}}
group=${group:-${RC_SVCNAME}}

command="/usr/bin/vault_exporter"
command_args="${command_args}"
command_background="true"
start_stop_daemon_args="--user ${user} --group ${group} \
--stdout /var/log/vault_exporter/${RC_SVCNAME}.log \
--stderr /var/log/vault_exporter/${RC_SVCNAME}.log"

depend() {
after net
}
11 changes: 11 additions & 0 deletions app-metrics/vault_exporter/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Manuel Rüger</name>
</maintainer>
<upstream>
<remote-id type="github">grapeshot/vault_exporter</remote-id>
</upstream>
</pkgmetadata>
40 changes: 40 additions & 0 deletions app-metrics/vault_exporter/vault_exporter-0.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit user golang-build golang-vcs-snapshot

MY_PV=${PV/_/}

EGO_PN="github.com/grapeshot/vault_exporter"
ARCHIVE_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Vault exporter for Prometheus"
HOMEPAGE="https://github.com/grapeshot/vault_exporter"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_compile() {
pushd src/${EGO_PN} || die
GOPATH="${S}" emake build || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
newbin _output/bin/vault_exporter-v${PV}* vault_exporter
dodoc README.md
popd || die
keepdir /var/log/vault_exporter
fowners ${PN}:${PN} /var/log/vault_exporter
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}

0 comments on commit 7ce7ecd

Please sign in to comment.