Skip to content

Commit

Permalink
app-benchmarks/sysbench: add snapshot
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
hydrapolic authored and gktrk committed Oct 27, 2016
1 parent 45caacb commit 7d2f5e8
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/sysbench/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sysbench-0.4.12.tar.gz 421932 SHA256 83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e SHA512 e5903a38c89ac850e7e8af6bba6a5311f8c14ab579eff794f9a7688f41804e8b53a8ababd4d1ea1c69625d53d9fe47842d123a6bc2c5fd74ffcac5bac488abbe WHIRLPOOL a880eba1464125817e8497e3492cd0ca20d751a73fd79d70777a41fbab85660152e09e27a8226fdd4424d615d748ca678dee991733b363c183c6618a8359bc3a
DIST sysbench-48124f838b00ff83a044fbf046a9d8d0b1602d90.tar.gz 281484 SHA256 d3619b4399e6a77a679932571402cfae85c9fd17541050a77006184b3cad155a SHA512 2dd9bb78343df27894094829708dc133009d8ee65399beafbf38ea88d42be311180a18bf7b76cd41b22482606b7de13840cbdf5fc5841a0d2ed59dd65e34cebe WHIRLPOOL 67874d43c2a1d6cda45f64edfe0961018c9b8f5b13cc68b35dfbcebc1f5c75d2bc0ecfc1cffdcc62fc783fcc8a4cabd0e1bbccea5546bcd907d649b6f3b17c71
59 changes: 59 additions & 0 deletions app-benchmarks/sysbench/sysbench-1.0_pre20161017.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

GITHUB_REV="48124f838b00ff83a044fbf046a9d8d0b1602d90"
MY_PN="${PN}-${GITHUB_REV}"

DESCRIPTION="System performance benchmark"
HOMEPAGE="https://github.com/akopytov/sysbench"

SRC_URI="https://github.com/akopytov/sysbench/archive/${GITHUB_REV}.tar.gz -> ${MY_PN}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="aio lua mysql postgres test"

RDEPEND="aio? ( dev-libs/libaio )
lua? ( dev-lang/lua:= )
mysql? ( virtual/libmysqlclient )
postgres? ( dev-db/postgresql:= )"
DEPEND="${RDEPEND}
sys-devel/libtool:=
dev-libs/libxslt
test? ( dev-util/cram )"

REQUIRED_USE="
mysql? ( lua )
postgres? ( lua )"

S="${WORKDIR}/${MY_PN}"

src_prepare() {
default

sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die

./autogen.sh || die
}

src_configure() {
local myeconfargs=(
$(use_enable aio aio)
$(use_with lua lua)
$(use_with mysql mysql)
$(use_with postgres pgsql)
--without-attachsql
--without-drizzle
--without-oracle
)

econf "${myeconfargs[@]}"
}

src_test() {
emake check test
}

0 comments on commit 7d2f5e8

Please sign in to comment.