Skip to content

Commit

Permalink
games-rpg/drascula: Drop games.eclass, make the game run again.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed May 1, 2018
1 parent 6c71292 commit 7d8c460
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
2 changes: 2 additions & 0 deletions games-rpg/drascula/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
DIST drascula-1.0.zip 32842993 BLAKE2B 5033e8e5f66f74c2b049a1246c62dd33b7b32c3d088575a8d031bc505cd3356c0b364efa9308c99e26e524dc58913cad7cc09424ac6ad30fff38175f952a0151 SHA512 74ca773264e1ed611456b230d6265dade8d745a3adb736f3d6583d43ed6820a25f481ec65612b31d4b3076418f6bc696c82fa0f5085ec43edc91761e95361d11
DIST drascula-1.5.0.dat 219267 BLAKE2B 1216bef8ef51e559a6d2a67c2a79c1f60613cf0f01d084864dbff10711d86512f01f69175ade2872fae8e0191ce45d3e0132259d84aac8598c6ff1490152c05b SHA512 0d788887f0cbe95f7008920d7929831d928497040ae0a2e2869c677363b693aafcf839df20ae192ec4a902f98a95771c9c45d3ec63c5a4bb1961e5f56d20fc53
DIST drascula-2.0.0.dat 219527 BLAKE2B 362cb71aa5c7ec7a391a9e371f7adbfeef7c3d015db562e613ebc5513d0d8661af6880549424c9fff0dde25e8fe3a82bc4658e0bd47eb6b65c071fff0dce9983 SHA512 b57cdde7f686d54b3dd669dc5737e0046c3f38a31c4f78cde1b51dc7dc3a28193a95d5364629716998f958b7c43ed45bdcd0bc32f94ca718e7882d16fea2c015
DIST drascula-audio-2.0.zip 36531704 BLAKE2B c3426f9c10e1ab5931b6474c1ba5b13a38267db5c8a8b8663e6a9bbea95751d50f4829dc427d962110ec4b0b093f2c5b59a73ca15aedd73c9ceaf1b3b158ec82 SHA512 09018bcfa062e720db6af7b38fa582f1b3674a25e7bb323d894ad767f8bcd449739fc592a10d848f6cac90a8bb51b5148c5c39558f70d29e2a5116b0b196274e
DIST drascula-int-1.1.zip 34855203 BLAKE2B b37f6ed68d3ef6cc70915d68178a0359ae39e9d2a020f84573e8e905ec4fa946ad9328479590d5510f0b03ec5a422a4204ffd3fb6294711ea7b68f0f19899151 SHA512 f8127d09e19dec9abf75b9129792c67f3d36ea80fa69c70eeaa536f7a76f8f29072c21f041a0f9467d595f214392541c09c7a75caca0318e8d1b587db9d099cf
DIST drascula.png 34525 BLAKE2B 1d529b02f08079921ab1021a3012fbef89fd4e9e4933727cdf96c5ce52bc3837d3f636e7b32f33cb92d027cbc330d4fc9280202a6b970821741eb8a44a905346 SHA512 e49fc17cad986b8fa42bd5ede30a1b1ef264182a476168d5c197a31d484555552e824f103b9456898940c68c2f0d751f4c2782a7a95ea92c62e3daec1dd1f52a
65 changes: 65 additions & 0 deletions games-rpg/drascula/drascula-1.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils

INT_PV="1.1"
INT_URI="mirror://sourceforge/scummvm/drascula-int-${INT_PV}.zip"
DAT_PV="2.0.0"
AUD_PV="2.0"

DESCRIPTION="Drascula: The Vampire Strikes Back"
HOMEPAGE="http://www.alcachofasoft.com/"
SRC_URI="mirror://sourceforge/scummvm/drascula-${PV}.zip
https://github.com/scummvm/scummvm/raw/v${DAT_PV}/dists/engine-data/drascula.dat -> drascula-${DAT_PV}.dat
sound? ( mirror://sourceforge/scummvm/drascula-audio-${AUD_PV}.zip )
https://salsa.debian.org/games-team/drascula/raw/master/debian/icons/drascula.png
l10n_es? ( ${INT_URI} )
l10n_de? ( ${INT_URI} )
l10n_fr? ( ${INT_URI} )
l10n_it? ( ${INT_URI} )"

LICENSE="drascula"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="l10n_es l10n_de l10n_fr l10n_it +sound"
RESTRICT="mirror"

RDEPEND=">=games-engines/scummvm-0.13.1"
DEPEND="${RDEPEND}
app-arch/unzip
"

S="${WORKDIR}"

src_unpack() {
if use l10n_es || use l10n_de || use l10n_fr || use l10n_it; then
unpack drascula-int-${INT_PV}.zip
fi
if use sound; then
unpack drascula-audio-${AUD_PV}.zip
fi
unpack drascula-${PV}.zip
}

src_install() {
local lang

make_wrapper ${PN} "scummvm -f -p \"/usr/share/${PN}\" drascula" .
for lang in es de fr it; do
if use l10n_${lang} ; then
make_wrapper ${PN}-${lang} "scummvm -q ${lang} -f -p \"/usr/share/${PN}\" drascula" .
make_desktop_entry ${PN}-${lang} "Drascula: The Vampire Strikes Back (${lang})" ${PN}
fi
done
insinto /usr/share/${PN}
find . -name "P*.*" -execdir doins '{}' +
newins "${DISTDIR}"/drascula-${DAT_PV}.dat drascula.dat
if use sound; then
doins audio/*
fi
dodoc readme.txt drascula.doc
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry ${PN} "Drascula: The Vampire Strikes Back"
}

0 comments on commit 7d8c460

Please sign in to comment.