forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-games/cegui: Fix build with ICU 59
Thanks-to: Lars Wendler (Polynomial-C) <[email protected]> Closes: https://bugs.gentoo.org/618968 Package-Manager: Portage-2.3.21, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
14 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -72,7 +72,7 @@ | ||
|
||
if ((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")) | ||
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99") | ||
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++03") | ||
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14") | ||
elseif (NOT CMAKE_VERSION VERSION_LESS "3.1") | ||
set (CMAKE_C_STANDARD_REQUIRED TRUE) | ||
set (CMAKE_C_STANDARD "99") |