Skip to content

Commit

Permalink
app-emacs/websocket: Initial import.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
ulm committed Nov 19, 2017
1 parent 85027e0 commit 7dd6db8
Show file tree
Hide file tree
Showing 3 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emacs/websocket/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST websocket-1.9.tar.gz 27029 SHA256 e7afbb5785e423e108119c9e625c9bab08297415224b07718f75ec6295130533 SHA512 bcd98e7edcbe95cae2f196cea05fd6cfa9083ed1ab2392530ca00cb05b87d6fa95b5f5319981fd94244b74989850c171e4c31c8758a8b7fe95d49299103a4410 WHIRLPOOL b0534b8c098569cebdf9ff597a459df7815f0e0a919c64fbbf4d8c64aa9789f0bbd585ca8adb139bb35254f29798e01e13eb417764a8bc0b1fbd20fa7ff564f7
8 changes: 8 additions & 0 deletions app-emacs/websocket/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo GNU Emacs project</name>
</maintainer>
</pkgmetadata>
31 changes: 31 additions & 0 deletions app-emacs/websocket/websocket-1.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
NEED_EMACS=24

inherit elisp

DESCRIPTION="A websocket implementation in elisp"
HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"

S="${WORKDIR}/emacs-${P}"

src_compile() {
elisp-compile websocket.el
}

src_test() {
${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
-f ert-run-tests-batch-and-exit
}

src_install() {
elisp-install ${PN} websocket.{el,elc}
dodoc README.org websocket-functional-test.el testserver.py
}

0 comments on commit 7dd6db8

Please sign in to comment.