Skip to content

Commit

Permalink
app-admin/filebeat: bump to 5.6.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
hydrapolic authored and Amynka committed Nov 16, 2017
1 parent c4cec85 commit 7e0f0eb
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/filebeat/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST filebeat-5.5.2.tar.gz 18075191 SHA256 39e792324a35fe84ef9a63cd5324252bc71d1c665188e8d597e12ca170cfde7a SHA512 ad92b41a9ceaad6c6e6fc80d0adccd7fe03a7056d121484bcf35c6a46b2061a5ef6d32121dd12d59b51e7678769da5c405b1d549fa130631ae3f1989b78fba48 WHIRLPOOL 46d182bd339abd26f3c4cf3f8d3a716180fc00147458f571eec34aefcaa67d9e88a561988e37c47083528024e4e0559b255c7a17efa43e0e4b21b653a575f7fd
DIST filebeat-5.6.3.tar.gz 18140948 SHA256 52a4c9094287f725a089e161dc71d9cdf0caf73595e8835a5d0636d3ad333bbe SHA512 6b3d61f18b1bd45db4ba5d08e92b94f1fb48610658237c91f4404a4074f82badbac2ab9bc236c1f64567a0dd1f62022c3d092a9017073069b4497c01f1b1d94b WHIRLPOOL 581b32645f6039d8f5d962db3a7216737af2673918a36f7826c6629a2e091efd2e87060c657883bf0ea1083992491e3cbf399774a75bf879bce142dd3d7c6065
DIST filebeat-5.6.4.tar.gz 18145215 SHA256 c06f913af79bb54825483ba0ed4b31752db5784daf3717f53d83b6b12890c0a4 SHA512 1ae66b7dd81f04434d667ecc295a747f8c650ba1affb88d7ae358051c739634b75c64d9c52d55fe6ee0b65848ff1825e508426c03d7e822517f55602091e186a WHIRLPOOL 37dbff315872dbbd5237aec2e32004a962b3f729f53d77e1f4cf86a094b2c0673499a408483c9a9be2be1521097f5dedb244c340fd05fe700b9d40291e83e58b
69 changes: 69 additions & 0 deletions app-admin/filebeat/filebeat-5.6.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
HOMEPAGE="https://www.elastic.co/products/beats"
SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND=">=dev-lang/go-1.8.3"
RDEPEND="!app-admin/filebeat-bin"

ELASTIC="${WORKDIR}/src/github.com/elastic"
BEATS="${ELASTIC}/beats"
S="${BEATS}"

src_unpack() {
mkdir -p "${ELASTIC}" || die
unpack ${P}.tar.gz
mv beats-${PV} "${BEATS}" || die
}

src_compile() {
cd ${BEATS}/filebeat || die
GOPATH="${WORKDIR}" emake
}

src_test() {
cd ${BEATS}/filebeat || die
GOPATH="${WORKDIR}" emake check
}

src_install() {
keepdir /var/{lib,log}/${PN}

fperms 0750 /var/{lib,log}/${PN}

newconfd "${FILESDIR}/${PN}.confd" ${PN}
newinitd "${FILESDIR}/${PN}.initd" ${PN}

insinto "/usr/share/doc/${PF}/examples"
doins ${PN}/{filebeat.yml,filebeat.full.yml}

insinto "/etc/${PN}"
doins ${PN}/{filebeat.template.json,filebeat.template-es2x.json,filebeat.template-es6x.json}

exeinto "/usr/share/${PN}"
doexe libbeat/scripts/migrate_beat_config_1_x_to_5_0.py

dobin filebeat/filebeat
}

pkg_postinst() {
if [[ -n "${REPLACING_VERSIONS}" ]]; then
elog "Please read the migration guide at:"
elog "https://www.elastic.co/guide/en/beats/libbeat/5.0/upgrading.html"
elog ""
elog "The migration script:"
elog "${EROOT%/}/usr/share/filebeat/migrate_beat_config_1_x_to_5_0.py"
elog ""
fi

elog "Example configurations:"
elog "${EROOT%/}/usr/share/doc/${PF}/examples"
}

0 comments on commit 7e0f0eb

Please sign in to comment.