Skip to content

Commit

Permalink
dev-lang/tcl: Bump to version 8.6.6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 8, 2016
1 parent a4b0445 commit 7e34efd
Show file tree
Hide file tree
Showing 2 changed files with 133 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/tcl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST tcl-core8.6.4-src.tar.gz 5813056 SHA256 373e849067f33159470060f35742110ff23b5fba07e42f01fbd0654d7a9a371f SHA512 cc73248b68528be46dbe1e29fa129bc827850e9a315ccd91bd0ca0afe61b8af633830a8da5706283de1c149df6cbf857da75ebd0f3998bb459e5456a4844a61f WHIRLPOOL 9b14d7dd31b2d8d1ca3bc44d4259514d8ff9df905a165fb7f95af018afffa1b87deeaf51ef602fd3d97a80c399687f842d24b539a301520dfeec172387de23b3
DIST tcl-core8.6.5-src.tar.gz 5846556 SHA256 10b6a0159e6bb458682b044726f544058a79ee2875644bd6755d2e69309fe963 SHA512 b726f7d3193ad92ba64911b8c724d5454c5a93d5f5e95462ec0a6d8ccbbdf20093888f66c83956d7631392ca805c1a80430f102c0a932de3ed55311101e0e09f WHIRLPOOL a4344efdf2d719678a3028044707331988e68bae827a252a735e33b29faab83cb6c3378fce8232b504b7474188611cc9c5aa43823f9fdb3e339bce4e3d798077
DIST tcl-core8.6.6-src.tar.gz 5868427 SHA256 4afa002eac0216bfd05643135ee8c227bac533daf4cee6c38a37e053c4b64696 SHA512 469a0221ed16569b70986cdde261d0c0df3bf64c493b8d6fc8368eb14597f7c2f6a01f082a1c8f27eb720618956e053cc97fbb9aaf7bb29cc96781cdc8e9518c WHIRLPOOL bcbf8a82d8197bea2814652b84390fd7d3fbb6e520ff0af0db7b355406954ed958bd43ac15b47c3df43ba747a70b3f4ef17d4d6ec0fe52ea0f15856c7e22c015
DIST tcl8.5.17-src.tar.gz 4546317 SHA256 4c7cd8f2e0900cb36dde899b3f9f4d5c471ee3c4f8304cf9ec71fd18cd5e98d6 SHA512 ad5ddb4cd6378fd6bbea8cd85ceb1cf90392b2e8c49fbfb3e4b35c81d3ae3e3f087697c41fcba8c8e06de1d9e7539397e26d58b864dc01ba65abe4ba4efa9568 WHIRLPOOL 7e97049eb3875bcdc33b2d8ab02b0932173916fbbdfbc7970dd3c3ed1fe520c15ed1d6106215a823b5fc6f5008f12f3ccd1525dd536ec239388e6bf459352ab6
132 changes: 132 additions & 0 deletions dev-lang/tcl/tcl-8.6.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,132 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils flag-o-matic multilib multilib-minimal toolchain-funcs versionator

MY_P="${PN}${PV}"

DESCRIPTION="Tool Command Language"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/tcl/${PN}-core${PV}-src.tar.gz"

LICENSE="tcltk"
SLOT="0/8.6"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE="debug +threads"

RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"

SPARENT="${WORKDIR}/${MY_P}"
S="${SPARENT}"/unix

PATCHES=(
"${FILESDIR}"/${PN}-8.5.13-multilib.patch

# Bug 125971
"${FILESDIR}"/${PN}-8.6.1-conf.patch
)

src_prepare() {
find \
"${SPARENT}"/compat/* \
"${SPARENT}"/doc/try.n \
-delete || die

pushd "${SPARENT}" &>/dev/null || die
default
popd &>/dev/null || die

# workaround stack check issues, bug #280934
use hppa && append-cflags "-DTCL_NO_STACK_CHECK=1"

tc-export CC

sed \
-e '/chmod/s:555:755:g' \
-i Makefile.in || die

sed \
-e 's:-O[2s]\?::g' \
-i tcl.m4 || die

mv configure.{in,ac} || die

eautoconf

multilib_copy_sources
}

multilib_src_configure() {
# We went ahead and deleted the whole compat/ subdir which means
# the configure tests to detect broken versions need to pass (else
# we'll fail to build). This comes up when cross-compiling, but
# might as well get a minor configure speed up normally.
export ac_cv_func_memcmp_working="yes"
export tcl_cv_str{str,toul,tod}_unbroken="ok"
export tcl_cv_strtod_buggy="no"

econf \
$(use_enable threads) \
$(use_enable debug symbols)
}

multilib_src_install() {
#short version number
local v1=$(get_version_component_range 1-2)
local mylibdir=$(get_libdir)

S= default
# fix the tclConfig.sh to eliminate refs to the build directory
# and drop unnecessary -L inclusion to default system libdir

sed \
-e "/^TCL_BUILD_LIB_SPEC=/s:-L$(pwd) *::g" \
-e "/^TCL_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-e "/^TCL_SRC_DIR=/s:${SPARENT}:${EPREFIX}/usr/${mylibdir}/tcl${v1}/include:g" \
-e "/^TCL_BUILD_STUB_LIB_SPEC=/s:-L$(pwd) *::g" \
-e "/^TCL_STUB_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-e "/^TCL_BUILD_STUB_LIB_PATH=/s:$(pwd):${EPREFIX}/usr/${mylibdir}:g" \
-e "/^TCL_LIB_FILE=/s:'libtcl${v1}..TCL_DBGX..so':\"libtcl${v1}\$\{TCL_DBGX\}.so\":g" \
-i "${ED}"/usr/${mylibdir}/tclConfig.sh || die
if use prefix && [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
sed \
-e "/^TCL_CC_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|g" \
-e "/^TCL_LD_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|" \
-i "${ED}"/usr/${mylibdir}/tclConfig.sh || die
fi

# install private headers
insinto /usr/${mylibdir}/tcl${v1}/include/unix
doins *.h
insinto /usr/${mylibdir}/tcl${v1}/include/generic
doins "${SPARENT}"/generic/*.h
rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/{tcl,tclDecls,tclPlatDecls}.h || die

# install symlink for libraries
dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a

if multilib_is_native_abi; then
dosym tclsh${v1} /usr/bin/tclsh
dodoc "${SPARENT}"/{ChangeLog*,README,changes}
fi
}

pkg_postinst() {
for version in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 8.6 ${version}; then
echo
ewarn "You're upgrading from <${P}, you must recompile the other"
ewarn "packages on your system that link with tcl after the upgrade"
ewarn "completes. To perform this action, please run revdep-rebuild"
ewarn "in package app-portage/gentoolkit."
ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
ewarn "upgrade them before this recompilation, too,"
echo
fi
done
}

0 comments on commit 7e34efd

Please sign in to comment.