Skip to content

Commit

Permalink
dev-scheme: use dostrip instead of RESTRICT
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/905898
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed May 16, 2023
1 parent 4698bec commit 7e3b8ea
Show file tree
Hide file tree
Showing 29 changed files with 190 additions and 56 deletions.
13 changes: 11 additions & 2 deletions dev-scheme/akku/akku-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -20,7 +20,7 @@ fi
LICENSE="GPL-3+"
SLOT="0"
# tests require network access
RESTRICT="strip test"
RESTRICT="test"

RDEPEND="
>=dev-scheme/guile-2.0.11:=
Expand All @@ -46,3 +46,12 @@ src_compile() {

emake
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
dostrip -x "/usr/$(get_libdir)/akku"
}
12 changes: 9 additions & 3 deletions dev-scheme/bytestructures/bytestructures-1.0.10.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -10,8 +10,6 @@ SRC_URI="https://github.com/TaylanUB/scheme-bytestructures/releases/download/v${
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="strip"

RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
Expand All @@ -34,3 +32,11 @@ src_prepare() {
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
11 changes: 9 additions & 2 deletions dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,7 +13,6 @@ S="${WORKDIR}/scheme-${PN}-${PV}"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
Expand All @@ -29,3 +28,11 @@ src_prepare() {
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
7 changes: 5 additions & 2 deletions dev-scheme/fibers/fibers-1.2.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,6 @@ SRC_URI="https://github.com/wingo/${PN}/archive/v${PV}.tar.gz
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND=">=dev-scheme/guile-2.1.7:="
DEPEND="${RDEPEND}"
Expand All @@ -35,5 +34,9 @@ src_prepare() {
src_install() {
default

find "${D}" -name "*.la" -delete || die
find "${ED}" -type f -name "*.la" -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
11 changes: 9 additions & 2 deletions dev-scheme/guile-config/guile-config-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -12,7 +12,6 @@ SRC_URI="https://gitlab.com/a-sassmannshausen/${PN}/-/archive/${PV}/${P}.tar.bz2
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
Expand All @@ -29,3 +28,11 @@ src_prepare() {

eautoreconf
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections. Bug https://bugs.gentoo.org/905898
dostrip -x /usr/$(get_libdir)/guile
}
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,7 +13,6 @@ S="${WORKDIR}"/guile-dbi-guile-dbi-${PV}/${PN}
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND="
dev-db/postgresql:*
Expand Down Expand Up @@ -41,4 +40,8 @@ src_install() {
default

find "${ED}" -type f -name "*.la" -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
7 changes: 5 additions & 2 deletions dev-scheme/guile-dbd-sqlite3/guile-dbd-sqlite3-2.1.8.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,7 +13,6 @@ S="${WORKDIR}"/guile-dbi-guile-dbi-${PV}/${PN}
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND="
dev-db/sqlite:3=
Expand Down Expand Up @@ -41,4 +40,8 @@ src_install() {
default

find "${ED}" -type f -name "*.la" -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
7 changes: 5 additions & 2 deletions dev-scheme/guile-dbi/guile-dbi-2.1.8.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,7 +13,6 @@ S="${WORKDIR}"/${PN}-${P}/${PN}
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
Expand All @@ -37,4 +36,8 @@ src_install() {
default

find "${ED}" -type f -name "*.la" -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
12 changes: 9 additions & 3 deletions dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,8 +13,6 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="strip"

RDEPEND="
>=dev-scheme/guile-2.0.11:=
Expand All @@ -35,3 +33,11 @@ src_prepare() {
# upstream tag on top of source tree. has no autogenerated files
eautoreconf
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
12 changes: 9 additions & 3 deletions dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,8 +13,6 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="strip"

RDEPEND="
>=dev-scheme/guile-2.0.11:=
Expand All @@ -35,3 +33,11 @@ src_prepare() {
# upstream tag on top of source tree. has no autogenerated files
eautoreconf
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
8 changes: 6 additions & 2 deletions dev-scheme/guile-gi/guile-gi-0.3.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -18,7 +18,7 @@ fi

LICENSE="GPL-3"
SLOT="0"
RESTRICT="strip test" # Tests fail
RESTRICT="test" # Tests fail

DEPEND="
>=dev-scheme/guile-2.0.9:=
Expand Down Expand Up @@ -50,4 +50,8 @@ src_install() {

mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
find "${ED}" -type f -name '*.la' -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections. Bug https://bugs.gentoo.org/905898
dostrip -x /usr/$(get_libdir)/guile
}
7 changes: 5 additions & 2 deletions dev-scheme/guile-gi/guile-gi-0.3.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -18,7 +18,6 @@ fi

LICENSE="GPL-3"
SLOT="0"
RESTRICT="strip"

DEPEND="
>=dev-scheme/guile-2.0.9:=
Expand Down Expand Up @@ -54,4 +53,8 @@ src_install() {

mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
find "${ED}" -type f -name '*.la' -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections. Bug https://bugs.gentoo.org/905898
dostrip -x /usr/$(get_libdir)/guile
}
7 changes: 5 additions & 2 deletions dev-scheme/guile-gi/guile-gi-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -18,7 +18,6 @@ fi

LICENSE="GPL-3"
SLOT="0"
RESTRICT="strip"

DEPEND="
>=dev-scheme/guile-2.0.9:=
Expand Down Expand Up @@ -54,4 +53,8 @@ src_install() {

mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
find "${ED}" -type f -name '*.la' -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections. Bug https://bugs.gentoo.org/905898
dostrip -x /usr/$(get_libdir)/guile
}
12 changes: 10 additions & 2 deletions dev-scheme/guile-git/guile-git-0.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"

# Works without sandbox. But under sandbox sshd claims to break the protocol.
RESTRICT="strip test"
RESTRICT="test"

# older libgit seems to be incompatible with guile-git bindings
# https://github.com/trofi/nix-guix-gentoo/issues/7
Expand Down Expand Up @@ -52,3 +52,11 @@ src_prepare() {
src_test() {
emake check VERBOSE=1
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
5 changes: 4 additions & 1 deletion dev-scheme/guile-gnutls/guile-gnutls-3.7.11-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,6 @@ SRC_URI="https://gitlab.com/gnutls/guile/uploads/56e18069ab63ca67d61aecb6b2697ec
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND="
>=dev-scheme/guile-2.0.0:=
Expand All @@ -38,4 +37,8 @@ src_install() {
default

find "${ED}" -type f -name "*.la" -delete || die

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
11 changes: 9 additions & 2 deletions dev-scheme/guile-hall/guile-hall-0.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -12,7 +12,6 @@ SRC_URI="https://gitlab.com/a-sassmannshausen/${PN}/-/archive/${PV}/${P}.tar.bz2
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND="
>=dev-scheme/guile-2.0.0:=
Expand All @@ -32,3 +31,11 @@ src_prepare() {

eautoreconf
}

src_install() {
default

# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}
Loading

0 comments on commit 7e3b8ea

Please sign in to comment.