forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Net-SSH-Perl: Bump to version 2.140.0
- Replace sed expr with patch - Killall authortests Upstream: - Add curve25519-sha256 alias - Fix handling unsupported key types - Add support for '-' in syntax options - Add wildcard support for '+' in syntax options - Fix reading ETM Mac input bytes - Fix DSA verification failure with r/s high-bit - Improve efficiency of CTR - Avoid warnings in Host from strange/invalid known_host entries - Make AES-CBC IV to be blocksize, not keysize - DES3 init now passed key as variable to avoid scalar error - Fix Packet padlen decode using signed instead of unsighed unpack - Fix key not being loaded prior to agent use - Fix DSA verification failure when r has unnecessary leading 0's Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
1 parent
fbec1b3
commit 7e41cd9
Showing
3 changed files
with
79 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST Net-SSH-Perl-1.36.tar.gz 117219 BLAKE2B ed23b89d5d4f8a32f875a12433cc7c6258273120fde596f496a2342d8f99786dd31ce6caa6c0b7418ffed7f0be400adf34232e16c131e8a50f5ee2ec856627f8 SHA512 4157d10a8dc107af17ab711102dea79b4b0b598d6c15d6f350f3a2eaf9be917c4410885d38de0dab4bbf1277875f03d5b10ca7350ba1300fdffc385c430c588f | ||
DIST Net-SSH-Perl-1.42.tar.gz 120783 BLAKE2B c8423aa71b679e67636f53c74b8158e4898bccfa5036eaeaf0150237548a249125fa203f3c986cd6e55a5ac1e7953f757e6914baf14286b36a9b51b808d7e604 SHA512 67275e99890948376c7f6feb5be1979f45b5fda2afe440108b3819db192fd41b43e9ee94e7e643671384b37972842f40ce3519cbeef98b6ee796a68e4bfe20dd | ||
DIST Net-SSH-Perl-2.09.01.tar.gz 255286 BLAKE2B fa299b63f1c82e5adc936513dc2fbda495abe087d32d80ffbf03bd9b9467114b710e7f74186514157b19c13259bde576c5f251aa038948a3114800b9ee675158 SHA512 e7d7194e175490ba0849357ebbb504932d97b358722f2045e0acbaba9c14dc945629bd5653b36934317632e0d3894525e4f34ea48b494f2cc815959106138b44 | ||
DIST Net-SSH-Perl-2.14.tar.gz 256963 BLAKE2B 700e9a852ab65ce881db043bf7ce775bbb60022299bf27936b90bb78c085136df1c6119b67f48bfd540b6b7cc2cb6406c252c4a6b9a7b73fc11760c28e527f58 SHA512 49fee3e7969260a97453adfdac7ed3852130a7404ca5016f6d16549e478b8f2808f47c5801f2dbf991cfb33b5f2653d55360ba938d9b36016620a46e1ffea879 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=SCHWIGON | ||
DIST_VERSION=2.14 | ||
DIST_EXAMPLES=("eg/*") | ||
inherit perl-module | ||
|
||
DESCRIPTION="Perl client Interface to SSH" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="minimal test" | ||
|
||
RDEPEND=" | ||
>=dev-perl/Crypt-Curve25519-0.50.0 | ||
dev-perl/Crypt-IDEA | ||
>=dev-perl/CryptX-0.32.0 | ||
virtual/perl-Digest-MD5 | ||
dev-perl/File-HomeDir | ||
virtual/perl-File-Spec | ||
virtual/perl-IO | ||
>=dev-perl/Math-GMP-1.40.0 | ||
virtual/perl-Scalar-List-Utils | ||
>=dev-perl/String-CRC32-1.200.0 | ||
!minimal? ( | ||
dev-perl/Digest-BubbleBabble | ||
dev-perl/Crypt-RSA | ||
dev-perl/TermReadKey | ||
) | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/perl-ExtUtils-MakeMaker | ||
test? ( >=virtual/perl-Test-Simple-0.610.0 ) | ||
" | ||
|
||
PERL_RM_FILES=( | ||
# Gentoo integrity checks are used instead | ||
'SIGNATURE' | ||
't/00-signature.t' | ||
# Annoying author tests | ||
't/99-perlcritic.t' | ||
't/99-pod.t' | ||
't/99-spellcheck.t' | ||
't/99-yaml.t' | ||
) | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.14-no-signatures.patch" | ||
) |
27 changes: 27 additions & 0 deletions
27
dev-perl/Net-SSH-Perl/files/Net-SSH-Perl-2.14-no-signatures.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
From ad32ac31952120cf20f8830233148188b6c26139 Mon Sep 17 00:00:00 2001 | ||
From: Kent Fredric <[email protected]> | ||
Date: Fri, 24 Mar 2017 05:10:15 +1300 | ||
Subject: Remove use of Module::Signature | ||
|
||
Gentoo has its own integrity protocols anyway, and even minor | ||
patching upsets signatures. | ||
|
||
Its not worth the added dependency complexity. | ||
--- | ||
Makefile.PL | 1 - | ||
|
||
diff --git a/Makefile.PL b/Makefile.PL | ||
index 0ff11dc..fa62a64 100644 | ||
--- a/Makefile.PL | ||
+++ b/Makefile.PL | ||
@@ -64,7 +64,6 @@ MSG | ||
} | ||
|
||
WriteMakefile( | ||
- (MM->can('signature_target') ? (SIGN => 1) : ()), | ||
NAME => 'Net::SSH::Perl', | ||
DISTNAME => 'Net-SSH-Perl', | ||
VERSION_FROM => 'lib/Net/SSH/Perl.pm', | ||
-- | ||
2.14.3 | ||
|