Skip to content

Commit

Permalink
app-editors/neovim: add remote USE flag.
Browse files Browse the repository at this point in the history
  • Loading branch information
lluixhi authored and monsieurp committed Jan 5, 2018
1 parent 68df739 commit 7ec4b11
Show file tree
Hide file tree
Showing 4 changed files with 168 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-editors/neovim/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -9,6 +9,7 @@
<flag name="clipboard">Enable clipboard support through a provider</flag>
<flag name="nvimpager">Install nvimpager symlink to less.sh macro</flag>
<flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations</flag>
<flag name="remote">Enable support for remote options using nvr</flag>
<flag name="tui">Build the neovim unix tui</flag>
<flag name="luajit">Use <pkg>dev-lang/luajit</pkg> instead of
<pkg>dev-lang/lua</pkg></flag>
Expand Down
82 changes: 82 additions & 0 deletions app-editors/neovim/neovim-0.2.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit cmake-utils

DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"

CDEPEND=">=dev-libs/libuv-1.2.0
>=dev-libs/msgpack-1.0.0
luajit? ( dev-lang/luajit:2 )
!luajit? (
dev-lang/lua:=
dev-lua/LuaBitOp
)
tui? (
>=dev-libs/libtermkey-0.19
>=dev-libs/unibilium-1.1.1
)
dev-libs/libvterm
dev-lua/lpeg[luajit=]
dev-lua/mpack[luajit=]
jemalloc? ( dev-libs/jemalloc )"

DEPEND="
${CDEPEND}
dev-util/gperf
virtual/libiconv
virtual/libintl"

RDEPEND="
${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
remote? ( dev-python/neovim-remote )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"

CMAKE_BUILD_TYPE=RelWithDebInfo

src_prepare() {
# use our system vim dir
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
-i src/nvim/globals.h || die

# add eclass to bash filetypes
sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DFEAT_TUI=$(usex tui)
-DENABLE_JEMALLOC=$(usex jemalloc)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

# install a default configuration file
insinto /etc/vim
doins "${FILESDIR}"/sysinit.vim

# conditionally install a symlink for nvimpager
if use nvimpager; then
dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
fi
}
82 changes: 82 additions & 0 deletions app-editors/neovim/neovim-0.2.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit cmake-utils

DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"

CDEPEND=">=dev-libs/libuv-1.2.0
>=dev-libs/msgpack-1.0.0
luajit? ( dev-lang/luajit:2 )
!luajit? (
dev-lang/lua:=
dev-lua/LuaBitOp
)
tui? (
>=dev-libs/libtermkey-0.19
>=dev-libs/unibilium-1.1.1
)
dev-libs/libvterm
dev-lua/lpeg[luajit=]
dev-lua/mpack[luajit=]
jemalloc? ( dev-libs/jemalloc )"

DEPEND="
${CDEPEND}
dev-util/gperf
virtual/libiconv
virtual/libintl"

RDEPEND="
${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
remote? ( dev-python/neovim-remote )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"

CMAKE_BUILD_TYPE=RelWithDebInfo

src_prepare() {
# use our system vim dir
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
-i src/nvim/globals.h || die

# add eclass to bash filetypes
sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DFEAT_TUI=$(usex tui)
-DENABLE_JEMALLOC=$(usex jemalloc)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

# install a default configuration file
insinto /etc/vim
doins "${FILESDIR}"/sysinit.vim

# conditionally install a symlink for nvimpager
if use nvimpager; then
dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
fi
}
5 changes: 3 additions & 2 deletions app-editors/neovim/neovim-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,12 +11,12 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+clipboard +luajit +nvimpager python ruby +tui +jemalloc"
IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"

CDEPEND=">=dev-libs/libuv-1.2.0
>=dev-libs/msgpack-1.0.0
Expand Down Expand Up @@ -44,6 +44,7 @@ RDEPEND="
${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
remote? ( dev-python/neovim-remote )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"

CMAKE_BUILD_TYPE=RelWithDebInfo
Expand Down

0 comments on commit 7ec4b11

Please sign in to comment.