Skip to content

Commit

Permalink
games-util/cartridges: add live 9999
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Sep 16, 2023
1 parent 338be24 commit 7ece46a
Showing 1 changed file with 58 additions and 0 deletions.
58 changes: 58 additions & 0 deletions games-util/cartridges/cartridges-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )

inherit gnome2-utils meson python-single-r1 xdg

DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
HOMEPAGE="https://github.com/kra-mo/cartridges/"

if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
else
SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-3+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
gui-libs/gtk:4[introspection]
gui-libs/libadwaita:1[introspection]
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-libs/appstream-glib
dev-util/blueprint-compiler
dev-util/desktop-file-utils
"

PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )

src_install() {
meson_src_install

python_fix_shebang "${ED}"/usr/bin
python_optimize "${ED}"/usr/share/cartridges/cartridges
}

pkg_postinst() {
gnome2_schemas_update
xdg_pkg_postinst
}

pkg_postrm() {
gnome2_schemas_update
xdg_pkg_postrm
}

0 comments on commit 7ece46a

Please sign in to comment.