Skip to content

Commit

Permalink
net-misc/electrum: Bump to 4.3.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 7, 2022
1 parent cf57d5d commit 7ed0df1
Show file tree
Hide file tree
Showing 2 changed files with 96 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/electrum/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST electrum-4.2.2.gh.tar.gz 5071636 BLAKE2B a13ae03e513736e5f24ded46a9b6ce13312a7d9243082f1d5b1948e7519f40f1fab238ec73550f72607ff2463a54a31f47c6ab8e511efddfcec362d5e427c6c1 SHA512 ae39ca0b548f3e4c7454096a7a05f9400a738e3b1c217ae9d41bf6156f7d642d3f1911f97829bfadbf6fdb6873538f38525363d256b363dac41d378c6b41002d
DIST electrum-4.3.0.gh.tar.gz 5436120 BLAKE2B 180fcbd7749888707e9e57a9117b1df98f248584d68a9edcea996a73a0fdbc78f0955f778af50afae1a7a02b0d12b4aefe58b8a63f59a2b220ecddb20126966f SHA512 305ff483de498c93b118422fdff0f67ba9522275d45a5f8b14040697647b58b8113e312fd6b14bf15d3cbba3907d978657dd99d8c02e199d8c936afa2b9a6407
95 changes: 95 additions & 0 deletions net-misc/electrum/electrum-4.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,95 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="ncurses?"

inherit desktop distutils-r1 xdg-utils

DESCRIPTION="User friendly Bitcoin client"
HOMEPAGE="
https://electrum.org/
https://github.com/spesmilo/electrum/
"
SRC_URI="
https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cli ncurses qrcode +qt5"
REQUIRED_USE="|| ( cli ncurses qt5 )"

RDEPEND="
${PYTHON_DEPS}
dev-libs/libsecp256k1
>=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
=dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
>=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
dev-python/bitstring[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
>=dev-python/dnspython-2[${PYTHON_USEDEP}]
dev-python/pbkdf2[${PYTHON_USEDEP}]
dev-python/PySocks[${PYTHON_USEDEP}]
dev-python/qrcode[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/protobuf-python-3.12[${PYTHON_USEDEP}]
qrcode? ( media-gfx/zbar[v4l] )
qt5? (
dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
)
ncurses? ( $(python_gen_impl_dep 'ncurses') )
"
BDEPEND="
test? (
dev-python/pyaes[${PYTHON_USEDEP}]
dev-python/pycryptodome[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_prepare() {
# use backwards-compatible cryptodome API
sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die

# make qdarkstyle dep optional
sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die

local bestgui
if use qt5; then
bestgui=qt
elif use ncurses; then
bestgui=text
else
bestgui=stdio
fi
sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die

eapply_user

xdg_environment_reset
distutils-r1_src_prepare
}

src_install() {
dodoc RELEASE-NOTES
distutils-r1_src_install
}

pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit 7ed0df1

Please sign in to comment.