Skip to content

Commit

Permalink
app-emulation/pcem: bump to version 16
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed May 19, 2020
1 parent fdae35d commit 7f002ca
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/pcem/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST PCemV15Linux.tar.gz 1741312 BLAKE2B fa8de8c98a57ac79be11921190960eaa1e5d53896db0749a7f53704362b6415544632a6f918a8f1ce57d2f75f28af52715856346421cc0a8355236a01bb7dcac SHA512 c2501827689acc0f3381d785dc3b008866e82d242bea3fa5af7e786fc58fdf72f76eafda98d12ce88c59ff338bc7dc441484af9c1bc9357c7cc75d94bbe0a7b6
DIST PCemV16Linux.tar.gz 1859892 BLAKE2B e388031e661b9320cc783e6400bdb7c191a2f946d9c207d9a58daa9270115b32ed55ac6a0b87227b51d10168e7d161bb03811eb83f5405ed1a71f7bfc6fd8aa5 SHA512 97d33ae1c4b59f281abe553ed4297c0d6c3956cf32b44474bfd5773700dd5c4ea6c209c679b9add5d4a7cba61748ee9794afa3c59af3230fa2a15812e13fd1c5
75 changes: 75 additions & 0 deletions app-emulation/pcem/pcem-16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools desktop wxwidgets

WX_GTK_VER="3.0"

DESCRIPTION="A PC emulator that specializes in running old operating systems and software"
HOMEPAGE="
https://pcem-emulator.co.uk/
https://bitbucket.org/pcem_emulator/pcem/
"
SRC_URI="https://pcem-emulator.co.uk/files/PCemV${PV}Linux.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="alsa networking"

S="${WORKDIR}"

RDEPEND="
alsa? ( media-libs/alsa-lib )
media-libs/libsdl2
media-libs/openal
x11-libs/wxGTK:${WX_GTK_VER}[tiff,X]
"

DEPEND="${DEPEND}"

BDEPEND="virtual/pkgconfig"

PATCHES=( "${FILESDIR}/${PN}-15-respect-cflags.patch" )

src_prepare() {
default

eautoreconf
}

src_configure() {
# Does not compile with -fno-common.
# See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
append-cflags -fcommon

local myeconfargs=(
--enable-release-build
$(use_enable alsa)
$(use_enable networking)
)

econf "${myeconfargs[@]}"
}

src_install() {
default

insinto /usr/share/pcem
doins -r configs nvr roms

newicon src/icons/32x32/motherboard.png pcem.png
make_desktop_entry "pcem" "PCem" pcem "Development;Utility"

dodoc readme.txt
}

pkg_postinst() {
elog "In order to use PCem, you will need some roms for various emulated systems."
elog "You can either install globally for all users or locally for yourself."
elog ""
elog "To install globally, put your ROM files into '${ROOT}/usr/share/pcem/roms/<system>'."
elog "To install locally, put your ROM files into '~/.pcem/roms/<system>'."
}

0 comments on commit 7f002ca

Please sign in to comment.