Skip to content

Commit

Permalink
dev-db/redis: add 6.2.13
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/910191
Signed-off-by: Petr Vaněk <[email protected]>
Closes: gentoo#31823
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
arkamar authored and thesamesam committed Jul 12, 2023
1 parent b0d749c commit 7f005e9
Show file tree
Hide file tree
Showing 2 changed files with 196 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/redis/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST redis-6.2.11.tar.gz 2492990 BLAKE2B edf046d86e295878abc5ba46ea6c8048c97f27b90d132ec1318350fa0634bb5e4cd1407757f07ef3c11abcb13b05ccc8a757bc17d7f1c9800644dfc0d2994d77 SHA512 9962446d7b1f14524a3007967768b33281dd33706567b8ac56e4cb7d3caa8533bcbc319ea899a163d56567be85cbc03cdcc440d9b1c9707372e10b53d1c1dcd7
DIST redis-6.2.12.tar.gz 2494460 BLAKE2B f7ac63c9c377743c158b435f954acf58db764f8ed70d5e76d13b814bf6316102eb9b0994477ac4629ff4fe94fef175735b95e7aa61f3ab69dd1caf63f39bf765 SHA512 cb955efacfd3ca9c526403f041d3500bfbd757137af46a1b76f2773ff835d9892f6a970cd9893f89f803aa2491f342b603c6208a08aad8f72f37feef4a03e8d1
DIST redis-6.2.13.tar.gz 2496004 BLAKE2B 91b6fcd72c1330aca358443c082967ed6f1ec27ecc2c1ea50e3824fb615a503710e75bac1cdc1c5305b95f2bea3bd43be21646dcbbdab85d401e832a3b5c7eea SHA512 644d02f357300cac3ef632f689dcf1786ad8a2c2ca68202bcd6dc6abfd728cc805e3ad3d99dbbe5503bf2ef5ce0cb8c11d3eab29aed780ae787094562e99c702
DIST redis-6.2.7.tar.gz 2487287 BLAKE2B 06f1b1e16cdf06c38b67c1f1dcccc025da50cc3719688b8c2bf23077d77dd97ea546909043fb65e60478ac3661cc033fa6e8d7a38e361e69eb93ba3db07b7c66 SHA512 d113094b8e31754915db7f0317d9b7969e034af3a7bac2ae0cbfad6cc61ba3aae35e9709c435abc1024a96f914df7a760b3cd18d06c375b541cfa837d1c5b953
DIST redis-7.0.10.tar.gz 2986993 BLAKE2B 94008c7801a9a0909b2b0131a45d4e0815648c7761d9a78c59be2cb03f6955678d7185c907f663bccd8a156851b61f76eaeca82dbd3beb5e64cc6ebf060e2ec2 SHA512 cb6376b8eb9bd56808d15b7a2289b39ad62ade618ab4b57314e6bda43a91905a4f222b32fa27fd4040e29e55ba4f4624452c246fb42fe3539c154954592efaa7
DIST redis-7.0.11.tar.gz 2988485 BLAKE2B b82c2dd9c81a2d92051814b07e6e3a886e52a1f46b9aa28124ad8850a5fec6a0b7bb86ec803c0e23c2c92fea0e2f29e7eca9f5f875d4396fdff9d1b54dbaf0e1 SHA512 679c908b87b4e513401b49d7b87ac1cb03a29dd145dc2364afd579dd541a38feb5d65ee9b7077bb6ec96c3850812bdd475ca10d5cf92ebe52839ff1a2be89174
Expand Down
195 changes: 195 additions & 0 deletions dev-db/redis/redis-6.2.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,195 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# Redis does NOT build with Lua 5.2 or newer at this time:
# - 5.3 and 5.4 give:
# lua_bit.c:83:2: error: #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
# - 5.2 fails with:
# scripting.c:(.text+0x1f9b): undefined reference to `lua_open'
# because lua_open became lua_newstate in 5.2
LUA_COMPAT=( lua5-1 luajit )

# Upstream have deviated too far from vanilla Lua, adding their own APIs
# like lua_enablereadonlytable, but we still need the eclass and such
# for bug #841422.
inherit autotools edo flag-o-matic lua-single multiprocessing systemd tmpfiles toolchain-funcs

DESCRIPTION="A persistent caching system, key-value, and data structures database"
HOMEPAGE="https://redis.io"
SRC_URI="https://download.redis.io/releases/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+jemalloc selinux ssl systemd tcmalloc test"
RESTRICT="!test? ( test )"

COMMON_DEPEND="
${LUA_DEPS}
jemalloc? ( >=dev-libs/jemalloc-5.1:= )
ssl? ( dev-libs/openssl:0= )
systemd? ( sys-apps/systemd:= )
tcmalloc? ( dev-util/google-perftools )
"

RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
selinux? ( sec-policy/selinux-redis )
"

BDEPEND="
${COMMON_DEPEND}
virtual/pkgconfig
"

# Tcl is only needed in the CHOST test env
DEPEND="
${COMMON_DEPEND}
test? (
dev-lang/tcl:0=
ssl? ( dev-tcltk/tls )
)"

REQUIRED_USE="?? ( jemalloc tcmalloc )
${LUA_REQUIRED_USE}"

PATCHES=(
"${FILESDIR}"/${PN}-6.2.1-config.patch
"${FILESDIR}"/${PN}-5.0-shared.patch
"${FILESDIR}"/${PN}-6.2.3-ppc-atomic.patch
"${FILESDIR}"/${PN}-sentinel-5.0-config.patch
)

src_prepare() {
default

# Copy lua modules into build dir
#cp "${S}"/deps/lua/src/{fpconv,lua_bit,lua_cjson,lua_cmsgpack,lua_struct,strbuf}.c "${S}"/src || die
#cp "${S}"/deps/lua/src/{fpconv,strbuf}.h "${S}"/src || die
# Append cflag for lua_cjson
# https://github.com/antirez/redis/commit/4fdcd213#diff-3ba529ae517f6b57803af0502f52a40bL61
append-cflags "-DENABLE_CJSON_GLOBAL"

# now we will rewrite present Makefiles
local makefiles="" MKF
for MKF in $(find -name 'Makefile' | cut -b 3-); do
mv "${MKF}" "${MKF}.in"
sed -i -e 's:$(CC):@CC@:g' \
-e 's:$(CFLAGS):@AM_CFLAGS@:g' \
-e 's: $(DEBUG)::g' \
-e 's:$(OBJARCH)::g' \
-e 's:ARCH:TARCH:g' \
-e '/^CCOPT=/s:$: $(LDFLAGS):g' \
"${MKF}.in" \
|| die "Sed failed for ${MKF}"
makefiles+=" ${MKF}"
done
# autodetection of compiler and settings; generates the modified Makefiles
cp "${FILESDIR}"/configure.ac-3.2 configure.ac || die

# Use the correct pkgconfig name for Lua.
# The upstream configure script handles luajit specially, and is not
# affected by these changes.
sed -i \
-e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \
-e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
-e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,${ELUA},g" \
configure.ac || die "Sed failed for configure.ac"
eautoreconf
}

src_configure() {
econf #$(use_with lua_single_target_luajit luajit)

# Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
# also, don't define ANSI/c99 for lua twice
sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
}

src_compile() {
local myconf=""

if use jemalloc; then
myconf+="MALLOC=jemalloc"
elif use tcmalloc; then
myconf+="MALLOC=tcmalloc"
else
myconf+="MALLOC=libc"
fi

if use ssl; then
myconf+=" BUILD_TLS=yes"
fi

export USE_SYSTEMD=$(usex systemd)

tc-export AR CC RANLIB
emake V=1 ${myconf} AR="${AR}" CC="${CC}" RANLIB="${RANLIB}"
}

src_test() {
local runtestargs=(
--clients "$(makeopts_jobs)" # see bug #649868
)

if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
ewarn "unit/oom-score-adj test will be skipped." \
"It is known to fail with FEATURES usersandbox or -userpriv. See bug #756382."

# unit/oom-score-adj was introduced in version 6.2.0
runtestargs+=( --skipunit unit/oom-score-adj ) # see bug #756382
fi

if use ssl; then
edo ./utils/gen-test-certs.sh
runtestargs+=( --tls )
fi

edo ./runtest "${runtestargs[@]}"
}

src_install() {
insinto /etc/redis
doins redis.conf sentinel.conf
use prefix || fowners -R redis:redis /etc/redis /etc/redis/{redis,sentinel}.conf
fperms 0750 /etc/redis
fperms 0644 /etc/redis/{redis,sentinel}.conf

newconfd "${FILESDIR}/redis.confd-r2" redis
newinitd "${FILESDIR}/redis.initd-6" redis

systemd_newunit "${FILESDIR}/redis.service-4" redis.service
newtmpfiles "${FILESDIR}/redis.tmpfiles-2" redis.conf

newconfd "${FILESDIR}/redis-sentinel.confd-r1" redis-sentinel
newinitd "${FILESDIR}/redis-sentinel.initd-r1" redis-sentinel

insinto /etc/logrotate.d/
newins "${FILESDIR}/${PN}.logrotate" ${PN}

dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md

dobin src/redis-cli
dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-rdb
fperms 0750 /usr/sbin/redis-benchmark
dosym redis-server /usr/sbin/redis-sentinel

if use prefix; then
diropts -m0750
else
diropts -m0750 -o redis -g redis
fi
keepdir /var/{log,lib}/redis
}

pkg_postinst() {
tmpfiles_process redis.conf

ewarn "The default redis configuration file location changed to:"
ewarn " /etc/redis/{redis,sentinel}.conf"
ewarn "Please apply your changes to the new configuration files."
}

0 comments on commit 7f005e9

Please sign in to comment.