forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST DisplayCAL-3.3.3.0.tar.gz 9887918 SHA256 47bcd09a44d43eb550fcd6f486d3f37c204a17b74fd9517991707856f54ca178 SHA512 2f9ac1ac2ce24629695f70078625ac4dc6e1346a675cd55658efc3631a6a37546cf6dc7b2747ae77b3681e7f7c816527497f53564e6cb51ce71a132d93955534 WHIRLPOOL 9b68dad41092d29fc7c15b34cfe3b1b034d7100eb8eeabbc1d9b1214c7670dc423fd9767830c2cf2ef007d2cc14238a0d608658206c76b0db59408d08daf863c | ||
DIST DisplayCAL-3.3.4.1.tar.gz 9909570 SHA256 0f4b15ef1b9bbc4ef5107651149373bb7c3dd76c524d55f9143b717e0fb0ad53 SHA512 c596333e298aea9366c808c074e467a49e32fa00b0534ae8ce6ad89d0250cf1f2a013dac0d87444edb911bcdea053a462026e335cfc2aa507a932217f1dcd272 WHIRLPOOL 0d74647f8876d6d97ccc9c969fd8a21264135f83b3db838702dd6545851670b89c48ed206ab247d885d3e80abe75378268be5a3b6c9db0981efab98a44f24fb0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit distutils-r1 xdg | ||
|
||
MY_PN="DisplayCAL" | ||
MY_P="${MY_PN}-${PV}" | ||
|
||
DESCRIPTION="Display calibration and characterization powered by Argyll CMS" | ||
HOMEPAGE="https://displaycal.net/" | ||
SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=media-gfx/argyllcms-1.1.0 | ||
dev-python/wxpython:3.0 | ||
>=x11-libs/libX11-1.3.3 | ||
>=x11-apps/xrandr-1.3.2 | ||
>=x11-libs/libXxf86vm-1.1.0 | ||
>=x11-proto/xineramaproto-1.2 | ||
>=x11-libs/libXinerama-1.1 | ||
" | ||
RDEPEND="${DEPEND} | ||
>=dev-python/numpy-1.2.1 | ||
" | ||
|
||
# Just in case someone renames the ebuild | ||
S="${WORKDIR}/${MY_P}" | ||
|
||
src_prepare() { | ||
# Do not generate udev/hotplug files | ||
sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \ | ||
-i DisplayCAL/setup.py || die | ||
# Prohibit setup from running xdg-* programs, resulting to sandbox violation | ||
sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \ | ||
-e '/if which/s#xdg-desktop-menu#\0-non-existant#' \ | ||
-i DisplayCAL/postinstall.py || die | ||
|
||
# Remove deprecated Encoding key from .desktop file | ||
sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die | ||
|
||
# Remove x-world Media Type | ||
sed -e 's/x\-world\/x\-vrml\;//g' \ | ||
-i misc/displaycal-vrml-to-x3d-converter.desktop || die | ||
|
||
distutils-r1_src_prepare | ||
} |