Skip to content

Commit

Permalink
dev-libs/gjs: Version bump to 1.72.0
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Mar 20, 2022
1 parent 5ec6eb6 commit 7f23bca
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/gjs/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gjs-1.64.4.tar.xz 422496 BLAKE2B a96211f7240336dbb30c6965e405f59ee72e4288842837da8da8c6d3c59b7e04ebb6c7a8b0b02d38601c162ffdf1a1fef9f13e4db720c4c483f4a39dffd5dbb4 SHA512 21a15d7106ad6584fb1f02cb0a0a4cab211a3540adb8f2c03d35c211e3946b81935000a52351fedd95a18a7ff6b7f96e665fcafa3c411ff79f2b6cb332c82b42
DIST gjs-1.64.5.tar.xz 422548 BLAKE2B dcc0b7327cbc6a1108be031c8807e61ebd3c8392916750078aaa0d82cb3bf9f7ff0e1876c250e5ddf6e9d7bb6a17d9d1fe34c1c77ff534b7ec1dd54fa05a2d1b SHA512 41a3c79888792674b2bccbf254507ed02497eb571c8ca7f47aab406d2ee29b73c98b1c7d59c33ed33bad90c6989df944d78b86d2f7e9824d598b62e29769b6dc
DIST gjs-1.70.1.tar.xz 598444 BLAKE2B 7d5f1b82e9edd20b9b3d3b03511d3cb8e19715d5dcaaa5375867c1c8754895db33089c41e17f28b732183ce510fff868399cd2174062684e0b3072cd599bc12b SHA512 194d8efeb37ecf7f3ea65c0bf0bbe2120524a11448423888d0785868297ebdea12b0ea4b28cb49d2596c7a3d73f13eb216072db8dca5e209193ba3dbbad78b6b
DIST gjs-1.72.0.tar.xz 620296 BLAKE2B 33665e66d548c6017bdc9ddb7409e1a21b07c9257bfa23ef35b58131037eefcf8ec5c8ffddbb1968db374f22729a6da873b85a022a2f3ed00168cba00acc7923 SHA512 224934eed511052d013cc7c2a29ccf79b14e5ed8c01db8071f07858387d7794b9156abd43ac494a13294248d9b6f2956d21c4e9581a41f5161043dff374f72f9
51 changes: 51 additions & 0 deletions dev-libs/gjs/gjs-1.72.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic gnome.org meson virtualx

DESCRIPTION="Javascript bindings for GNOME"
HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"

LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
SLOT="0"
IUSE="+cairo examples gtk readline sysprof test"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-libs/glib-2.66.0
dev-libs/libffi:=
>=dev-libs/gobject-introspection-1.66.1:=
>=dev-lang/spidermonkey-91.3.0:91
cairo? ( x11-libs/cairo[X,glib,svg] )
readline? ( sys-libs/readline:0= )
"
DEPEND="${RDEPEND}
sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
test? ( sys-apps/dbus
>=x11-libs/gtk+-3.20:3[introspection] )
"
BDEPEND="
virtual/pkgconfig
"

src_configure() {
append-cppflags -DG_DISABLE_CAST_CHECKS

# FIXME: add systemtap/dtrace support, like in glib:2
local emesonargs=(
$(meson_feature cairo)
$(meson_feature readline)
$(meson_feature sysprof profiler)
-Dinstalled_tests=false
$(meson_use !test skip_dbus_tests)
$(meson_use !test skip_gtk_tests)
)
meson_src_configure
}

src_test() {
virtx meson_src_test
}

0 comments on commit 7f23bca

Please sign in to comment.