Skip to content

Commit

Permalink
games-rpg/freedroidrpg: version bump
Browse files Browse the repository at this point in the history
- 1.0RC2 version bump
- Port to EAPI 7
- Add new USE flags for development or debugging.

Closes: https://bugs.gentoo.org/699772
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andrew Savchenko <[email protected]>
  • Loading branch information
bircoph committed Nov 11, 2019
1 parent c2640d0 commit 7f39c43
Show file tree
Hide file tree
Showing 3 changed files with 119 additions and 41 deletions.
1 change: 1 addition & 0 deletions games-rpg/freedroidrpg/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST freedroidRPG-0.16.tar.gz 225570013 BLAKE2B ad87ad3d368c94eb1f3dae2d4c3df97b9bc88acccbec4cbcd31e42b411bb96506faac23f8de9b0317a1ab926b34bd01196adce617ab7b731354049d3fb010643 SHA512 039ee4bfcd58e29a3cfa26ae7f2bc8aed7c289119476bb8f8486006910cf6a2127ba49f7526fac887392ca9e5320fb1a59ba068834e162348905423908b0755a
DIST freedroidRPG-1.0rc2.tar.gz 233852127 BLAKE2B c87c2314d17037873acf4fc24ce20790c9ec40c8f7b1ea27e6ab9c543abb671bc50b3ff5b86900f7111d1f1a899213dcb90529d2e39918801c9cc3a42585f02e SHA512 a79afdb089691dd59b0128f34f7068c69fac8c057a0485bca3275f4914b1c9c0f21cbb9102ecdc99911b70456c078dbdeb8981fd7714836cd9535677bcc4d1e7
97 changes: 97 additions & 0 deletions games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
inherit autotools flag-o-matic desktop python-any-r1 xdg

MY_PV=$(ver_rs 2 '')
DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
HOMEPAGE="http://www.freedroid.org"
SRC_URI="ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-$(ver_cut 1-2)/freedroidRPG-${MY_PV}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug devtools nls opengl profile sanitize sound"

RDEPEND="
sys-libs/zlib
virtual/jpeg:0
media-libs/libpng:0
media-libs/libsdl[opengl?,sound?,video]
media-libs/sdl-image[jpeg,png]
>=media-libs/sdl-gfx-2.0.21
nls? ( virtual/libintl )
opengl? ( virtual/opengl )
sound? (
media-libs/libogg
media-libs/libvorbis
media-libs/sdl-mixer[vorbis] )
devtools? ( media-libs/sdl-ttf )"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
nls? ( sys-devel/gettext )
sanitize? ( || ( sys-devel/gcc[sanitize] sys-devel/clang-runtime[sanitize] ) )"

S="${WORKDIR}/${PN}-${MY_PV^^}"

src_prepare() {
default

sed -i \
-e '/^dist_doc_DATA/d' \
-e '/-pipe/d' \
-e '/^SUBDIRS/s/pkgs//' \
Makefile.am || die
python_fix_shebang src data/sound
eautoreconf
}

src_configure() {
# this can produce strange results due to 'imprecise' math computations
filter-flags -ffast-math

local myconf=(
--disable-fastmath
--with-embedded-lua
--localedir=/usr/share/locale
$(use_enable nls)
$(use_enable opengl)
$(use_enable sound)
$(use_enable debug)
$(use_with debug extra-warnings)
$(use_enable debug backtrace)
$(use_enable sanitize sanitize-address)
$(use_enable profile rtprof)
$(use_enable devtools dev-tools)
)
econf "${myconf[@]}"
}

src_install() {
local i

default
for i in 48 64 96 128
do
doicon -s ${i} pkgs/freedesktop/icons/hicolor/${i}x${i}/apps/"${PN}".png
done
doicon -s scalable pkgs/freedesktop/icons/hicolor/scalable/apps/freedroidRPG.svg
make_desktop_entry "${PN}" "Freedroid RPG" "${PN}"
}

pkg_postinst() {
xdg_pkg_postinst

local v min="1.0_rc1"
for v in ${REPLACING_VERSIONS}; do
if ver_test "${v}" -lt "${min}"; then
echo
ewarn "${P} is not compatible with save games before ${min}."
ewarn "Please start a new character."
echo
fi
done
}
62 changes: 21 additions & 41 deletions games-rpg/freedroidrpg/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,49 +6,29 @@
<name>Gentoo Games Project</name>
</maintainer>
<longdescription>
Hello, and welcome to the Freedroid page.
FreedroidRPG is an open source role playing game

THE CLASSICAL FREEDROID: Freedroid is a clone of the classic game
"Paradroid" on Commodore 64 with some improvements and extensions to
the classic version.
The game tells the story of a world destroyed by a conflict between robots and
their human masters. Play as Tux in a quest to save the world from the
murderous rebel bots who know no mercy. You get to choose which path you wish
to follow, and freedom of choice is everywhere in the game.

In this game, you control a robot, depicted by a small white ball with
a few numbers within an interstellar spaceship consisting of several
decks connected by elevators.
FreedroidRPG features a real time combat system with melee and ranged weapons,
fairly similar to the proprietary game Diablo. There is an innovative system of
programs that can be run in order to take control of enemy robots, alter their
behavior, or improve one's characteristics. You can use over 50 different kinds
of items and fight countless enemies on your way to your destiny. An advanced
dialog system provides story background and immersive role playing situations.

The aim of the game is to destroy all enemy robots, depicted by small
black balls with a few numbers, by either shooting them or seizing
control over them by creating connections in a short subgame of
electric circuits.

Development of this game is now complete. The final version came out
in august 2003 and runs on Linux, Mac OSX, Sharp Zaurus and even that
strange Windows wannabe of an operating system. Thanks to all who
helped.
Minor fixes and maintainance will of course still continue though...

FREEDROID RPG: The Freedroid RPG is an extension/modification of the
classical freedroid engine into an RPG. The main differences to the
classical version are as follows:
* The Tux is the main character of the rpg. He is not displayed as a
ball like in Freedroid but rather as an animated character, while
other droids and humans in the game are still represented as the balls
with some number or code in them.
* Dialogs and chatting with friendly droids and humans:
Multiple-choice menus and voice samples (with subtitles for those
without sound).
* Melee weapons, armour and other items to be equipped have been
added.
* An automap feature was added.
* Saving and loading of games.
* A shop to trade things.
* Controls are different: Mouse can be used to do everything.
Joystick is not supported for moving around any more.
* The archive size (including sound samples) is about 10 times as big
as for the classical version. I'd like to appologize to all 56K modem
owners at this point.
The game is complete, fully playable, and can provide about 10 hours of fun. It
is still being actively developed, and help is welcome in many areas. People
having - or trying to acquire - programming, map editing, or writing skills
will find FreedroidRPG to be an exciting, fast-moving project in which they can
fully express their creativity.
</longdescription>
<upstream>
<remote-id type="sourceforge">freedroid</remote-id>
</upstream>
<use>
<flag name="devtools">Compile the additional dev tools</flag>
<flag name="profile">Enable the integration of the ingame real-time profiler</flag>
<flag name="sanitize">Compile with address sanitizer</flag>
</use>
</pkgmetadata>

0 comments on commit 7f39c43

Please sign in to comment.