Skip to content

Commit

Permalink
app-arch/unrar: add 6.2.3
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Dec 16, 2022
1 parent 04fe35e commit 7f4537a
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/unrar/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST unrar-6.1.7.tar.gz 236798 BLAKE2B e33a7500b4a03a54f84b018ab90934366f52ef54c83257ed7fe4419ba993d2a8c21de26f445ae18d870aa5232cfbf1f5d8fbc0b3965803aeec6cac5e5a38e949 SHA512 b1a95358ff66b0e049597bbc4e1786d0bc909a8aff4aca94ee793d0d5a3c8b052eb347d88f44b6bc2e6231e777f1b711c198711118ae9ffbe8db2f72e7fbe846
DIST unrar-6.2.1.tar.gz 242918 BLAKE2B 55cd5d11caae2e6cef2a36f5656b76d96946d6d7df3f34d7c65cc31b43b820d955da4751666797f8147c6a7b20c3429527b2b1629842334d3bec6de49e1d6a72 SHA512 920819b4b3e76004492813b4c22309443976fe5e7c873032bc084603b902c6873775cb90cb173d78de3624a3161a2238c9ece1e817f6b7d915937e2e18d8def9
DIST unrar-6.2.2.tar.gz 243051 BLAKE2B 3f76476d8cfd2fb56c6d98c8a5698c7dbdba518566384051f5b645fc5e0661ec662aeee713641cf180819984c6e1d3a44f16d8afa0c99d95ae8007916feb82ea SHA512 8edc659599f9e7a325e7db0ffdf57775295880c4368c4b37881390e0633b1f41d66799263e7cb85cc658e395b6eb0ff9e495aa0fd870b971422c4369a2e6c1b5
DIST unrar-6.2.3.tar.gz 245210 BLAKE2B 85dc22e52404a57286a19c901543aaeffd4526a2f7653f35b4d60c8c7c0965401f9b9658f79b1a06fc56365268a7c4895a560f04cff5d926fbc20ffa4f3d8f10 SHA512 070d027134210db930500f612bae41390af53d810160f8e5368640b6afee1a26650fc3473f8b563248b47ecc082dfd30b6fca318de6539c7795ac93af39f3357
65 changes: 65 additions & 0 deletions app-arch/unrar/unrar-6.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit multilib toolchain-funcs

MY_PN="${PN}src"

DESCRIPTION="Uncompress rar files"
HOMEPAGE="https://www.rarlab.com/rar_add.htm"
SRC_URI="https://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/unrar"

LICENSE="unRAR"
SLOT="0/6" # subslot = soname version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"

PATCHES=(
"${FILESDIR}"/${PN}-5.9.3-build.patch
"${FILESDIR}"/${PN}-5.5.5-honor-flags.patch
)

src_prepare() {
default

local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" )
if [[ ${CHOST} == *-darwin* ]] ; then
sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" )
else
sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" )
fi
sed -i "${sed_args[@]}" makefile || die
}

src_configure() {
mkdir -p build-{lib,bin} || die
printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die
cp build-{lib,bin}/Makefile || die
}

src_compile() {
unrar_make() {
emake AR="$(tc-getAR)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
}

unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib
ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die
ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die

unrar_make -C build-bin
}

src_install() {
dobin build-bin/unrar
dodoc readme.txt

dolib.so build-lib/libunrar*

insinto /usr/include/libunrar${PV%.*.*}
doins *.hpp
dosym libunrar${PV%.*.*} /usr/include/libunrar

find "${ED}" -type f -name "*.a" -delete || die
}

0 comments on commit 7f4537a

Please sign in to comment.