Skip to content

Commit

Permalink
kde-apps/okular: Add USE=kde, fix CamelCase switch
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
a17r authored and Michael Palimaka committed Dec 10, 2015
1 parent 161ebda commit 7f4cb44
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-apps/okular/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@
<flag name="chm">Enable support for Microsoft Compiled HTML Help files</flag>
<flag name="dpi">DPI detection support for PDF rendering via <pkg>x11-libs/libkscreen</pkg></flag>
<flag name="ebook">Add E-Book support</flag>
<flag name="kde">Enable kactivities support</flag>
<flag name="mobi">Add mobipocket support</flag>
</use>
<herd>kde</herd>
Expand Down
59 changes: 59 additions & 0 deletions kde-apps/okular/okular-15.08.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="optional"

#VIRTUALX_REQUIRED=test
RESTRICT=test
# test 2: parttest hangs

inherit kde4-base

DESCRIPTION="Okular is a universal document viewer based on KPDF for KDE 4"
HOMEPAGE="https://okular.kde.org https://www.kde.org/applications/graphics/okular"
KEYWORDS=" ~amd64 ~x86"
IUSE="chm crypt debug djvu dpi ebook +jpeg kde mobi +postscript +pdf +tiff"

DEPEND="
media-libs/freetype
media-libs/qimageblitz
sys-libs/zlib
chm? ( dev-libs/chmlib )
crypt? ( app-crypt/qca:2[qt4] )
djvu? ( app-text/djvu )
dpi? ( x11-libs/libkscreen:4 )
ebook? ( app-text/ebook-tools )
jpeg? (
$(add_kdeapps_dep libkexiv2)
virtual/jpeg:0
)
kde? ( $(add_kdebase_dep kactivities '' 4.13.3) )
mobi? ( $(add_kdeapps_dep kdegraphics-mobipocket) )
pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
postscript? ( app-text/libspectre )
tiff? ( media-libs/tiff:0 )
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with chm)
$(cmake-utils_use_with crypt QCA2)
$(cmake-utils_use_with djvu DjVuLibre)
$(cmake-utils_use_with dpi LibKScreen)
$(cmake-utils_use_with ebook EPub)
$(cmake-utils_use_with jpeg)
$(cmake-utils_use_with jpeg Kexiv2)
$(cmake-utils_use_with kde KActivities)
$(cmake-utils_use_with mobi QMobipocket)
$(cmake-utils_use_with postscript LibSpectre)
$(cmake-utils_use_with pdf PopplerQt4)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with tiff)
)

kde4-base_src_configure
}

0 comments on commit 7f4cb44

Please sign in to comment.