Skip to content

Commit

Permalink
app-i18n/yaskkserv: avoid phase function call
Browse files Browse the repository at this point in the history
Gentoo-Bug: 596620

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Jun 25, 2017
1 parent fe2909d commit 7f50276
Show file tree
Hide file tree
Showing 2 changed files with 21 additions and 17 deletions.
6 changes: 3 additions & 3 deletions app-i18n/yaskkserv/files/yaskkserv.initd
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
#!/sbin/openrc-run
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

command=/usr/sbin/${SVCNAME}_${YASKKSERV_SERVER_TYPE}
command="/usr/sbin/${SVCNAME}_${YASKKSERV_SERVER_TYPE}"
command_args="--no-daemonize ${YASKKSERV_OPTS}"
command_background="true"
pidfile=${pidfile:-/run/${SVCNAME}.pid}
pidfile="${pidfile:-/run/${SVCNAME}.pid}"

depend() {
need net
Expand Down
32 changes: 18 additions & 14 deletions app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -48,20 +48,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
}

pkg_postinst() {
pkg_config

elog "You need to run:"
elog " emerge --config =${CATEGORY}/${PF}"
elog "after updating app-i18n/skk-jisyo from next time."
}

pkg_postrm() {
rm -f "${ROOT}"/usr/share/skk/SKK-JISYO.*.${PN}
rmdir "${ROOT}"/usr/share/skk 2>/dev/null
}

pkg_config() {
yaskkserv_update() {
local f
for f in "${ROOT}"/usr/share/skk/SKK-JISYO.*; do
case ${f} in
Expand All @@ -76,3 +63,20 @@ pkg_config() {
esac
done
}

pkg_postinst() {
yaskkserv_update

elog "You need to run:"
elog " emerge --config =${CATEGORY}/${PF}"
elog "after updating app-i18n/skk-jisyo from next time."
}

pkg_postrm() {
rm -f "${ROOT}"/usr/share/skk/SKK-JISYO.*.${PN}
rmdir "${ROOT}"/usr/share/skk 2>/dev/null
}

pkg_config() {
yaskkserv_update
}

0 comments on commit 7f50276

Please sign in to comment.