Skip to content

Commit

Permalink
games-emulation/gngeo: build with gcc5 (bug #571056); respect CFLAGS
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Michael Sterrett committed Mar 31, 2016
1 parent a2a3f83 commit 7f66870
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 3 deletions.
41 changes: 41 additions & 0 deletions games-emulation/gngeo/files/gngeo-0.8-cflags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
--- configure.in.orig 2016-03-31 04:15:45.913917791 -0400
+++ configure.in 2016-03-31 04:16:23.447607551 -0400
@@ -236,20 +236,12 @@
AC_DEFINE(PROCESSOR_INTEL, 1, [Define if you have an x86 processor])
ALIGNLONGS=0
proc_i386=true
- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
- -ffast-math -falign-functions=2 -falign-jumps=2 -fexpensive-optimizations \
- -falign-loops=2 -fschedule-insns2 -malign-double -fomit-frame-pointer -g \
- -fno-strict-aliasing -pipe -mtune=$target_cpu -DCPU=$target_cpu"
;;
x86_64)
AC_MSG_RESULT(Turning on x86_64 processor optimisations)
AC_DEFINE(PROCESSOR_ADM64, 1, [Define if you have an x86_64 processor])
ALIGNLONGS=0
proc_x64=true
- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
- -ffast-math -fexpensive-optimizations \
- -malign-double -fomit-frame-pointer -g \
- -fno-strict-aliasing -pipe -DCPU=$target_cpu"
;;
sparc*) AC_MSG_RESULT(Turning on sparc processor optimisations)
AC_DEFINE(PROCESSOR_SPARC, 1, [Define if you have a sparc processor])
@@ -258,8 +250,6 @@
if test $target_cpu = sparc64 && test $CC_MAJOR -ge 3 ; then
CFLAGS="$CFLAGS -mcpu=v9"
fi
- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
- -ffast-math -fomit-frame-pointer -g"
;;
arm) AC_MSG_RESULT(Turning on arm processor optimisations)
AC_DEFINE(PROCESSOR_ARM, 1, [Define if you have an ARM processor])
@@ -273,8 +263,6 @@
*) AC_MSG_RESULT(Processor type unknown - Use generic optimisations)
ALIGNLONGS=1
optimum=no
- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
- -ffast-math -g"
;;
esac

8 changes: 5 additions & 3 deletions games-emulation/gngeo/gngeo-0.8.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils autotools games
inherit eutils autotools flag-o-matic games

DESCRIPTION="A NeoGeo emulator"
HOMEPAGE="https://code.google.com/p/gngeo/"
Expand All @@ -23,9 +23,11 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-execstacks.patch \
"${FILESDIR}"/${P}-zlib.patch \
"${FILESDIR}"/${P}-concurrentMake.patch
"${FILESDIR}"/${P}-concurrentMake.patch \
"${FILESDIR}"/${P}-cflags.patch
mv configure.in configure.ac || die
eautoreconf
append-cflags -std=gnu89 # build with gcc5 (bug #571056)
}

src_configure() {
Expand Down

0 comments on commit 7f66870

Please sign in to comment.