forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/ranger: Version bump (v1.9.3)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <[email protected]>
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST ranger-1.9.2.tar.gz 265295 BLAKE2B 93e4d8ff1ad41c9bdf94af4a3ed9ab013048d1a601242553592b0e246f000b3a0226644b126ae7ec1c70562ff80b3f6c6711ee0e53dc1b7363c9ddf8f5fa75cc SHA512 5eb4743beaf0478d745cce8e5bfc2ac07c98ab5784e9394772782d06c0bb27dcd5478ead191ac527f21cce76db09a51eb46db0fabc7993684a6b5aaec0d43104 | ||
DIST ranger-1.9.3.tar.gz 280363 BLAKE2B 2698f82773aae0224e7385413a1f939cdd4b3374eddad496781a42b054e26a8d7e5944bf19bc846736a9171df317c0dbc3c8bdf83c6ca9bdb95de17f9229809e SHA512 5cd7bea714a6542d0a5445f5f0cf929b2df4377df3ef710f3786c6c46dd58b017a8060cde3969076637bfaac03c13297d3020fd82f4574dc49546ca223c0e8d3 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} ) | ||
PYTHON_REQ_USE="ncurses" | ||
|
||
inherit distutils-r1 | ||
|
||
if [[ ${PV} == "9999" ]] ; then | ||
EGIT_REPO_URI="https://github.com/ranger/ranger.git" | ||
inherit git-r3 | ||
else | ||
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
fi | ||
|
||
DESCRIPTION="A vim-inspired file manager for the console" | ||
HOMEPAGE="https://ranger.github.io/" | ||
LICENSE="GPL-3" | ||
SLOT="0" | ||
|
||
RDEPEND="virtual/pager" | ||
|
||
distutils_enable_tests pytest | ||
|
||
src_prepare() { | ||
# use versioned doc path | ||
sed -i "s|share/doc/ranger|share/doc/${PF}|" setup.py doc/ranger.1 || die | ||
|
||
distutils-r1_src_prepare | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ -z ${REPLACING_VERSIONS} ]]; then | ||
elog "Ranger has many optional dependencies to support enhanced file previews." | ||
elog "See the README or homepage for more details." | ||
fi | ||
} |