Skip to content

Commit

Permalink
dev-ruby/bson: add 4.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Feb 28, 2020
1 parent 775a4e4 commit 7f9625e
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/bson/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST bson-4.5.0.tar.gz 107547 BLAKE2B fddbb84ee74c3b6bb50a79141e583b300deeaa85b7
DIST bson-4.6.0.tar.gz 115899 BLAKE2B cae63b799cba6a464988937b26bc47533e8ca5089c3a1f5e4bc8cf01e11eaa1f5bd82b79f144b2bafd7cae8478743c3ccedfe8c839ff45db907c77b5e1c6d1a4 SHA512 9661b394d6d45caef7d10df439ca5a65869fa4dcde49158f818e7c2764a31976c615bacf09a09a8bcf2bab2e2d78a64be1a7fdad68e796facd071f972b1f5635
DIST bson-4.7.0.tar.gz 120354 BLAKE2B 8399eb5c3658ed23b6aaac93144c7b1047143b3bc0f1a4610a2ce168a350f04d814f1929a3fcc6efdfcb453abfc54199091c8fbb034a837aab065e7c9814ab70 SHA512 34289260f37e0c72de26219ada8843a44044f61316217c2a4157187bd2d5e871e1578415c09107c65d78496ad388985dfbdc8dec562d3e3aace2bf4bef7ab6fb
DIST bson-4.7.1.tar.gz 120690 BLAKE2B fbb6eeca2b339eaa80503294cefd1c97abb9f992ce1068bbf64a6ffa9239fabb6df4c982c90ab3522362c5bbe55bbaf479023a2f5f2e24ffb86a1dd8fae80db3 SHA512 75026ab81abf5f629200b008a3a8da38a594751c43335eb0c8e29bc94848d2dfce9479419de136b8176dde5d2cc9e66ceb5a7d2b52cfacdb1813a1c63871fa95
DIST bson-4.8.0.tar.gz 151255 BLAKE2B b15bde922ae882d372815d8b6e0ed8a6f8b79c2fe6fd6d361a31bacf3acdaec4376d5331276aac8fcafc641c7d72cef9c5a99e485cb8f738cf9318336cbd4500 SHA512 284c8686a34018eb04223b391dff4f771d5b83f7e7d9fda8fcc4e2ae8c15ffca52a7ef5049cc866b0dc62d3761ede442eaaecfe19c8381256510c9902e850b01
43 changes: 43 additions & 0 deletions dev-ruby/bson/bson-4.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
USE_RUBY="ruby24 ruby25 ruby26 ruby27"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

GITHUB_USER="mongodb"
GITHUB_PROJECT="bson-ruby"

inherit multilib ruby-fakegem

DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
HOMEPAGE="https://www.mongodb.org/"
SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
RUBY_S="bson-ruby-${PV}"

LICENSE="APSL-2"
SLOT="4"
KEYWORDS="~amd64"
IUSE="test doc"

all_ruby_prepare() {
# Remove bundler support
sed -i -e '/bundler/I s:^:#:' Rakefile || die

# Remove project-specific rspec options
rm .rspec || die
}

each_ruby_configure() {
${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
}

each_ruby_compile() {
emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
cp ext/bson/*$(get_modname) lib/ || die
}

0 comments on commit 7f9625e

Please sign in to comment.