Skip to content

Commit

Permalink
dev-python/healpy: initial import
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
sfabbro committed Apr 7, 2016
1 parent 5407c47 commit 7ff820b
Show file tree
Hide file tree
Showing 3 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/healpy/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST healpy-1.9.1.tar.gz 4043342 SHA256 b88fcd667e0bf474335811018cb97932b5f9d5575f22d2237b6707844a121c23 SHA512 84427e4fdb01ed534a00617ba707a58f4ed21ba0114fcc3f7bd4748cefaad148c9025bfc7a4c77c1de40b7f69dfb53139f2b347e80955f4631609cd50e70cd5a WHIRLPOOL 2c8e5fe751fbfe12b699ff154c6f0472bbd7d758b0e18d249984d51567398e9eeea26ee9d79bb086fd79af4b4c4afa0f1f8c3a6c369acd1a4f91a7f8ebd7081a
39 changes: 39 additions & 0 deletions dev-python/healpy/healpy-1.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} )

inherit distutils-r1

DESCRIPTION="Python wrapper for healpix"
HOMEPAGE="https://github.com/healpy"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

RDEPEND="
dev-python/astropy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
sci-astronomy/healpix:=[cxx]
sci-libs/cfitsio:="
DEPEND="${RDEPEND}
dev-python/astropy-helpers[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

DOCS=( README.rst CHANGELOG.rst CITATION )

python_test() {
echo "backend: Agg" > matplotlibrc || die
MPLCONFIGDIR=. esetup.py test || die
rm matplotlibrc || die
}
17 changes: 17 additions & 0 deletions dev-python/healpy/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
<longdescription lang="en">
Healpy provides a python package to manipulate healpix maps. It is
based on the standard numeric and visualisation tools for Python,
Numpy and matplotlib.
</longdescription>
<upstream>
<remote-id type="pypi">healpy</remote-id>
<remote-id type="github">healpy/healpy</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 7ff820b

Please sign in to comment.