forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mate-base/mate-control-center: Adjust subslot deps on x11-wm/marco
Closes: https://bugs.gentoo.org/694136 Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Adam Feldman <[email protected]>
- Loading branch information
1 parent
aafcfc8
commit 7ffce83
Showing
2 changed files
with
71 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
70 changes: 70 additions & 0 deletions
70
mate-base/mate-control-center/mate-control-center-1.22.2-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,70 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
MATE_LA_PUNT="yes" | ||
|
||
inherit mate | ||
|
||
if [[ ${PV} != 9999 ]]; then | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
fi | ||
|
||
DESCRIPTION="The MATE Desktop configuration tool" | ||
LICENSE="FDL-1.1+ GPL-2+ LGPL-2+ LGPL-2.1+ HPND" | ||
SLOT="0" | ||
|
||
IUSE="accountsservice appindicator debug" | ||
|
||
RDEPEND=" | ||
dev-libs/atk | ||
>=dev-libs/dbus-glib-0.73 | ||
>=dev-libs/glib-2.50:2 | ||
dev-libs/libxml2:2 | ||
>=gnome-base/dconf-0.13.4 | ||
>=gnome-base/librsvg-2.0:2 | ||
>=mate-base/libmatekbd-1.17.0 | ||
>=mate-base/mate-desktop-1.21.2 | ||
>=mate-base/caja-1.20.0 | ||
>=mate-base/mate-menus-1.21.0 | ||
>=mate-base/mate-settings-daemon-1.21.2 | ||
>=media-libs/fontconfig-1:1.0 | ||
media-libs/freetype:2 | ||
media-libs/libcanberra:0[gtk3] | ||
>=sys-apps/dbus-1 | ||
x11-apps/xmodmap | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/gtk+-3.22:3 | ||
x11-libs/libX11 | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXcursor | ||
x11-libs/libXext | ||
>=x11-libs/libXi-1.5 | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
>=x11-libs/libxklavier-4 | ||
x11-libs/pango | ||
>=x11-wm/marco-1.17.0:= | ||
virtual/libintl | ||
accountsservice? ( sys-apps/accountsservice ) | ||
appindicator? ( dev-libs/libappindicator:3 )" | ||
|
||
DEPEND="${RDEPEND} | ||
app-text/rarian | ||
>=app-text/scrollkeeper-dtd-1:1.0 | ||
app-text/yelp-tools | ||
dev-util/desktop-file-utils | ||
dev-util/glib-utils | ||
>=dev-util/intltool-0.50.1 | ||
sys-devel/gettext | ||
x11-base/xorg-proto | ||
virtual/pkgconfig" | ||
|
||
src_configure() { | ||
mate_src_configure \ | ||
--disable-update-mimedb \ | ||
$(use_enable appindicator) \ | ||
$(use_enable debug) | ||
} |