forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
www-client/opera-developer: Version 53.0.2900.0.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Jeroen Roovers
committed
Mar 20, 2018
1 parent
51f7658
commit 8028da4
Showing
2 changed files
with
115 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST opera-developer_53.0.2885.0_amd64.deb 54539420 BLAKE2B adda26647ef8b194ce1c99f0ad3d963ce35c2a7957a3150c01bc420b6eef59806a1ab807f49d64931c72e23e215db5f99d5aadbb72de680c2a7ea9619c1799ae SHA512 ef9398b3c090e7a77654943a2b394960604859d4daf133f1bc1b713523edfb4eafcd8e7f9b3023142a9115043ce3bedb6a9db0fc48d27007c145dedf8455c4d0 | ||
DIST opera-developer_53.0.2893.0_amd64.deb 54587290 BLAKE2B fd551f17bc15235908723b6ecf5c5c21443317a22d0b1fc359191084744c5d88070a2d16c6deedd8aff0d1a7b415574d2455328f5d2805dc89fe6f06bc2741f5 SHA512 72d4bd41d48f43c450c6a27cd19503c0e9f8c2b7ddd950697026f0d6b462eed34de278d2ab3fe70c56275473b1237559548ea2694d1d94a0e5d67a754466b2fa | ||
DIST opera-developer_53.0.2900.0_amd64.deb 54722634 BLAKE2B 227ed778c707e4d689466910a926a1081c0d8624439230dbd3778de73057dd52763a429960bd83e9ac474e71435970c39a12e2f192957f72243291e5160a95cf SHA512 3af9adac5659b41b1120e6b1e5905674199a33610d6457c6fa0b5d96b46c03358183afafaf239679c5777273429a61aafd6e290530b7bd82e553961dfecd399d |
114 changes: 114 additions & 0 deletions
114
www-client/opera-developer/opera-developer-53.0.2900.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,114 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
CHROMIUM_LANGS=" | ||
be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it | ||
ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi | ||
zh-CN zh-TW | ||
" | ||
inherit chromium-2 gnome2-utils multilib unpacker xdg-utils | ||
|
||
DESCRIPTION="A fast and secure web browser" | ||
HOMEPAGE="http://www.opera.com/" | ||
LICENSE="OPERA-2014" | ||
SLOT="0" | ||
SRC_URI_BASE=" | ||
http://download1.operacdn.com/pub/ | ||
http://download2.operacdn.com/pub/ | ||
http://download3.operacdn.com/pub/ | ||
http://download4.operacdn.com/pub/ | ||
" | ||
SRC_URI="amd64? (" | ||
for uri in ${SRC_URI_BASE}; do | ||
SRC_URI+=" | ||
"${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb" | ||
" | ||
done | ||
SRC_URI+=")" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=" | ||
dev-libs/expat | ||
dev-libs/glib:2 | ||
dev-libs/nspr | ||
dev-libs/nss | ||
gnome-base/gconf:2 | ||
media-libs/alsa-lib | ||
media-libs/fontconfig | ||
media-libs/freetype | ||
net-misc/curl | ||
net-print/cups | ||
sys-apps/dbus | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf | ||
x11-libs/gtk+:3 | ||
x11-libs/libX11 | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXcomposite | ||
x11-libs/libXcursor | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXi | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
x11-libs/libXtst | ||
x11-libs/libnotify | ||
x11-libs/pango[X] | ||
" | ||
|
||
QA_PREBUILT="*" | ||
S=${WORKDIR} | ||
OPERA_HOME="usr/$(get_libdir)/${PN}" | ||
|
||
src_unpack() { | ||
unpack_deb ${A} | ||
} | ||
|
||
src_prepare() { | ||
case ${ARCH} in | ||
amd64) | ||
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die | ||
rm -r usr/lib || die | ||
;; | ||
x86) | ||
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die | ||
;; | ||
esac | ||
|
||
rm usr/bin/${PN} || die | ||
|
||
rm usr/share/doc/${PN}/copyright || die | ||
mv usr/share/doc/${PN} usr/share/doc/${PF} || die | ||
|
||
pushd "${OPERA_HOME}/localization" > /dev/null || die | ||
chromium_remove_language_paks | ||
popd > /dev/null || die | ||
|
||
sed -i \ | ||
-e 's|^TargetEnvironment|X-&|g' \ | ||
usr/share/applications/${PN}.desktop || die | ||
} | ||
|
||
src_install() { | ||
mv * "${D}" || die | ||
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN} | ||
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
xdg_desktop_database_update | ||
xdg_mimeinfo_database_update | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_icon_cache_update | ||
xdg_desktop_database_update | ||
xdg_mimeinfo_database_update | ||
} |